Exhibits: One image isn't enough for nice exhibits

Bug #920542 reported by Matthew Paul Thomas on 2012-01-23
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Software Center Agent
Medium
Łukasz Czyżykowski
software-center (Ubuntu)
Medium
Michael Vogt

Bug Description

(I thought I had reported this already. Sorry if it's a duplicate.)

Currently exhibits can have only one image. So they can't, for example, have one image for the logo and text, and another image for the background.

This is one of the two things causing USC banners to be lopsided to the left. (The other being that USC barfs if a banner is "100%" wide.)

It would be much nicer to be able to upload up to, say, three images per exhibit.

Related branches

Anthony Lenton (elachuni) wrote :

It should be relatively simple to make exhibits have a list of images, instead of just a single background image.

This will require a client update, so lets implement this in a backwards-compatible way if possible.

Changed in software-center-agent:
status: New → Confirmed
importance: Undecided → Medium
summary: - One image isn't enough for nice exhibits
+ Exhibits: One image isn't enough for nice exhibits
Danny Tamez (zematynnad) on 2012-07-09
Changed in software-center-agent:
assignee: nobody → Danny Tamez (zematynnad)
status: Confirmed → In Progress
Danny Tamez (zematynnad) wrote :

After looking at this today it seems that it would be better to change from a one page form to more of a wizard style interface. I say this because we can't use the images they upload until the form has been posted and the file now resides on the server. If we did this in a wizard format we could first ask them to fill out the basics like name, published, etc and then ask them for a background image. The form is submitted and the next step shows them the background image. We then ask them for text and/or a logo image. The form is again submitted and we return to them a preview of the logo/text on the background and the raw html that is used to render them. They can then tweak the html and get instant feedback in the preview area.

Anthony, mpt let me know what you think of this. Also, mpt, could you please explain the use case for needing more than a bg image and a logo image? If more are necessary then I suppose when we ask for the logo image we could also have them upload any other images they want and then display them in some arbitrary fashion in the preview and they can tweak the html to make them look correct.

What do you think?

Matthew Paul Thomas (mpt) wrote :

I can't predict the kind of creative uses we might find for more than two images. However, it's already possible and useful for backgrounds alone to use multiple images.
<http://www.css3.info/preview/multiple-backgrounds/>
<http://event-horizon.kicks-ass.net/cargo_bay/css3_multiple_backgrounds/>
If you add a logotype on top of that, you're already using three images, not two.

Ideally, I think the form would dynamically add upload fields as you need them. Specify one file and it adds a second field, specify a second file and it adds a third field, choose "Remove" and the associated upload field disappears too, etc.

Michael Nelson (michael.nelson) wrote :

Although the fix for this bug (and bug 1046261) enable multiple exhibits to be specified on sca, USC still needs to be updated before it can display exhibits with multiple images.

Currently USC stores a local copy of exhibit.banner_url (which will be the first image), and then replaces the server_path in the html with that image [2]. Assuming that the non-absolute URLs are required in the html (? is that for a webkit security policy? The code at [2] seems to be dependent on the banner url being a non-absolute url. Otherwise we could simply put the absolute urls in the html), USC will simply need to cycle through all the exhibit.banner_urls doing the same replace (I think?)

[1] Original conversation https://irclogs.canonical.com/2012/09/06/%23ca-internal.html#t14:46
[2] http://bazaar.launchpad.net/~ubuntu-branches/ubuntu/quantal/software-center/quantal/view/head:/softwarecenter/ui/gtk3/widgets/exhibits.py#L150

Changed in software-center-agent:
assignee: Danny Tamez (zematynnad) → Łukasz Czyżykowski (lukasz-czyzykowski)
Dave Morley (davmor2) wrote :

SCA is set to fix committed pending the USC work to test it full, once that is in place I will move them to fix released.

Changed in software-center-agent:
status: In Progress → Fix Committed
tags: added: ca-escalated
Changed in software-center-agent:
status: Fix Committed → Fix Released
Dave Morley (davmor2) on 2012-09-17
Changed in software-center (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
Michael Vogt (mvo) on 2012-09-24
Changed in software-center (Ubuntu):
status: Triaged → In Progress
Changed in software-center (Ubuntu):
status: In Progress → Fix Committed
assignee: nobody → Michael Vogt (mvo)
Dave Morley (davmor2) on 2012-09-27
Changed in software-center-agent:
milestone: none → 12.08.2
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 5.3.14.3

---------------
software-center (5.3.14.3) quantal; urgency=low

  [ Michael Vogt ]
  * lp:~mvo/software-center/downloader-fix-race839462-again:
    - fix a race condition in the SimpleFileDownloader when the file
      is downloaded but the signal did not get delivered yet by the
      gtk event loop (LP: #1055441)
  * lp:~mvo/software-center/thumbnail-test-fixes:
    - fix the get_test_screenshot_thumbnail_window() function and
      ensure that its properly used in the automatic test
  * lp:~mvo/software-center/support-multiple-exhibit-images:
    - add support for multiple images in the exhibit banners
      (LP: #920542)
  * lp:~mvo/software-center/robustness-lp1054070:
    - extends the recovery mechanism for corrupted berkeley
      DB files to MemoryErrors as well to catch LP: #1054070
  * lp:~mvo/software-center/whats-new-lp1044033:
    - ensure that there is a fallback xapian value that can be
      used if the apt-xapian-index has not been created
      (LP: #1044033)
  * lp:~mvo/software-center/exact-match-duplication-lp891613:
    - fix the duplication of packages during a search if there
      is an exact pkgname match in the apt-xapian-index and
      also in the software-center-agent (LP: #891613)
  * lp:~mvo/software-center/lp1047494:
    - fix AttributeError crash in _on_reviews_ready_callback()
      (LP: #1047494)
  * lp:~mvo/software-center/de-duplication-multiple-pkgnames-lp1043159:
    - fix duplication for multiple package lists (LP: #1043159)

  [ Stéphane Graber ]
  * lp:~stgraber/software-center/fix-weblive-isinstance:
    - sync weblive_pristine.py to the latest upstream version,
      this includes porting to be pep8 and python 3 ready and
      restores correct weblive operation

  [ Gary Lasker ]
  * lp:~gary-lasker/software-center/de-duplication-multiple-pkgnames-lp1043159-tweak
    - pass DB to the recommendations categories
 -- Michael Vogt <email address hidden> Tue, 02 Oct 2012 10:02:51 +0200

Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers