If an app is installed on maverick the deb line in natty still shows maverick

Bug #780812 reported by Dave Morley on 2011-05-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Software Center Agent
High
Unassigned
Ubuntu Software Center
Invalid
Undecided
Unassigned
software-center (Ubuntu)
Critical
Michael Vogt

Bug Description

Bug Description:
If an app is installed on maverick the deb line in natty still shows maverick.

On my fresh natty install the deb lines for uplink is deb https://<user>:<passwordkey>@private-ppa.launchpad.net/commercial-ppa-uploaders/uplink/ubuntu maverick main #Added by software-center

This would mean any fixes specific to natty weren't picked up by the natty install as it is pulling in the maverick version.

Version:
n/a

OS:
64bit Natty

Browser:
FF 4.0

Problem URL:
n/a

Steps To Reproduce:
1. open software-center add lines for previously purchased apps
2. open /etc/apt/sources.list.d/application_name check the contents of the file

Expected Result:
I expect to see my installed os version in the deb line in order to obtain the correct versions of the software.

Related branches

Dave Morley (davmor2) on 2011-05-11
tags: added: bug-1
Changed in software-center-agent:
status: New → Confirmed
importance: Undecided → High
Michael Vogt (mvo) on 2011-10-07
Changed in software-center:
status: New → Invalid
Changed in software-center (Ubuntu):
status: New → Triaged
importance: Undecided → High
tags: added: client-server
Michael Vogt (mvo) on 2012-03-14
Changed in software-center-agent:
importance: High → Critical
importance: Critical → High
Changed in software-center (Ubuntu):
status: Triaged → In Progress
importance: High → Critical
milestone: none → ubuntu-12.04-beta-2
Michael Nelson (michael.nelson) wrote :

software-center-agent was already updated to provide the supported distroseries as part of the fix for bug 917109 which was done to be able to fix the USC bug 833982 (which is quite related to this).

As a result, at least for precise, when the user views their previous purchases, they will only have an install button if their series is supported, in which case it is safe to replace the distroseries segment of the purchased deb_line with the current distroseries, afaict.

Changed in software-center (Ubuntu):
assignee: nobody → Gary Lasker (gary-lasker)
assignee: Gary Lasker (gary-lasker) → Michael Vogt (mvo)
status: In Progress → Fix Committed
Changed in software-center-agent:
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (4.6 KiB)

This bug was fixed in the package software-center - 5.1.13

---------------
software-center (5.1.13) precise; urgency=low

  [ Anthony Lenton ]
  * lp:~elachuni/software-center/pep8-test-part5,
    lp:~elachuni/software-center/pep8-test-part6,
    lp:~elachuni/software-center/pep8-test-part7,
    lp:~elachuni/software-center/pep8-test-part8,
    lp:~elachuni/software-center/pep8-test-part9,
    lp:~elachuni/software-center/pep8-test-part10,
    lp:~elachuni/software-center/pep8-test-part11,
    lp:~elachuni/software-center/pep8-test-part12,
    lp:~elachuni/software-center/pep8-test-part13,
    lp:~elachuni/software-center/pep8-test-part14,
    lp:~elachuni/software-center/pep8-test-part15,
    lp:~elachuni/software-center/pep8-test-part16,
    lp:~elachuni/software-center/pep8-test-part17,
    lp:~elachuni/software-center/pep8-test-part18,
    lp:~elachuni/software-center/pep8-test-part19,
    lp:~elachuni/software-center/pep8-test-part20,
    lp:~elachuni/software-center/pep8-test-part21,
    lp:~elachuni/software-center/pep8-test-part22:
    - many, many, many pep8 fixes
  * lp:~elachuni/software-center/unify-ussoc-envvar:
    - fix USSOC_SERVICE_URL env variable

  [ Gabor Kelemen ]
  * lp:~kelemeng/software-center/bug953812: (LP: #953812)
    - Translate review sorting criteria
    - Fix the Recommendation spinner text translations

  [ Michael Vogt ]
  * lp:~mvo/software-center/small-sso-fixes:
    - fix the clear_credentials() call if a token is no
      longer valid
  * lp:~mvo/software-center/lp955005:
    - don't display ratings for the case where an app
      cannot be found (LP: #955005)
  * lp:~mvo/software-center/opengl-driver-blacklist:
    - add support for video driver blacklisting
  * lp:~mvo/software-center/lp856559:
    - fix case where the search term is not always
      cleared in the search entry (LP: #856559)
  * lp:~mvo/software-center/misc-fixes:
    - when a package can not be authenticated, do not fail
      (hard) but instead offer to "repair" the situation using
      a "reload" and try the install again (LP: #876278)
    - do not crash in if os.makedirs has a race condition
      (LP: #956680)
    - fix the proxy handling with 12.04 as the "enabled" property
      is deprecated now. it will also not mess with the proxy
      environment on non-gnome systems (LP: #742564)
  * lp:~mvo/software-center/lp780812:
    - ensure that the distroseries is updated in the sources
      deb line when updating a purchased item (LP: #780812)
  * lp:~mvo/software-center/recommendations-opt-out:
    - fix double-results when opting-in and back out of of
      the recommendations service repeatedly
  * lp:~mvo/software-center/tos-dialog:
    - display a terms-of-service dialog before the first purchase
  * lp:~mvo/software-center/lp957599:
    - add a new unit test test_spawn_helper.py
  * lp:~mvo/software-center/track-db-open:
    - improve db logging

  [ Gary Lasker ]
  * lp:~gary-lasker/software-center/fix-lp955048:
    - String fix for the "Recommended For You" panel. LP: #955048
  * lp:~gary-lasker/software-center/fix-lp856559:
    - Clears the search entry field before doing a reinstall
      previous purchases (LP: #85655...

Read more...

Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers