"activate" item is missing from indicator menu.

Bug #863190 reported by Eugene San on 2011-09-30
34
This bug affects 5 people
Affects Status Importance Assigned to Milestone
sni-qt
Fix Released
Undecided
Unassigned
sni-qt (Ubuntu)
Medium
Unassigned

Bug Description

"activate" item is missing from indicator menu therefor there is no way to access application main window.

Revision history for this message
Robert Roth (evfool) wrote :

Confirming based on downstream (Ubuntu ) duplicate bug #863257, should be bumped to Medium, as this affects all the users, and sni-qt becomes quite useless, if only the right-click menu can be accessed, as some apps use the "activate"/left click on the old systray icon to show/hide window (e.g. skype) and without this, there's no way to show skype e.g. if started minimized.

Changed in sni-qt:
status: New → Confirmed
Changed in sni-qt (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
Revision history for this message
Dmitry Pankratov (dremon) wrote :

I had the same issue with sni-qt:i386; after reinstalling the package it seems to be fixed.

Revision history for this message
Aurélien Gâteau (agateau) wrote :

Sni-qt provides a way to "fix" applications which do not provide any menu item to trigger the left-click action, this is documented in the README: http://bazaar.launchpad.net/~agateau/sni-qt/trunk/view/head:/README

The Ubuntu package comes with a few applications preconfigured: clementine, mumble, skype and speedcrunch. Let us know any application which would be missing so that it can be added to the default config file.

Changed in sni-qt:
status: Confirmed → Fix Released
Changed in sni-qt (Ubuntu):
status: Confirmed → Incomplete
Revision history for this message
zzarko (zzarko-gmail) wrote :

Similar thing happens (in 11.10) with qjoypad program (uses Qt): left-click should display configuration dialog, while right-click shows list of defined configurations. Since in 11.10 left-click is same as the right-click, configuration window cannot be opened. This worked as it should in 11.04.

Revision history for this message
TheCat (chris-shaffer) wrote :

Why can't I change back to the former behavior? I want left click on the tray icon to "activate" the program. I don't need to duplicate the right click behavior with a left click...

Revision history for this message
Aurélien Gâteau (agateau) wrote : Re: [Bug 863190] Re: "activate" item is missing from indicator menu.

Le 25/10/2011 17:20, TheCat a écrit :
> Why can't I change back to the former behavior? I want left click on
> the tray icon to "activate" the program. I don't need to duplicate the
> right click behavior with a left click...

The design of appindicators is to avoid having to figure out which
buttons does what, hence the decision to behave the same whether you are
using left or right button.

You can work-around the fact that there is no way to show the window by
following the steps documented here:

http://bazaar.launchpad.net/~agateau/sni-qt/trunk/view/head:/README

Eugene San (eugenesan) on 2012-04-24
Changed in sni-qt (Ubuntu):
status: Incomplete → Fix Released
Revision history for this message
zzarko (zzarko-gmail) wrote :

In which version of sni-qt is this solved? I have a 12.04 installation, sni-qt is 0.2.5-0ubuntu3, and the bug is still present.

Revision history for this message
rusk (dmitrysushkov77) wrote :

13.04 same here
sni-qt version is 0.2.6-0ubuntu1

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

Hi rusk could you please open a new bug and link it here?
the original reported said his bug was fixed, so this can be a different issue.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers