store allows some characters in description which can't be removed

Bug #1795416 reported by Alan Pope 🍺🐧🐱 πŸ¦„ on 2018-10-01
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Snap Store
High
Adam Collard
Snapcraft
Status tracked in Trunk
Legacy
High
Sergio Schvezov
Trunk
High
Adam Collard
Software Center Agent
High
Adam Collard

Bug Description

Somehow a developer has managed to add the following text to their store description.

"Snap store entry [DO NOT DELETE}"

They cannot fix this because when editing it errors with:-

"ValueError: Single '}' encountered in format string"

Adam Collard (adam-collard) wrote :

Thank you for taking the time to report this bug and helping to make snapcraft better. Unfortunately, we cannot work on this bug because your description didn't include enough information. You may find it helpful to read "How to report bugs effectively" http://www.chiark.greenend.org.uk/~sgtatham/bugs.html. We'd be grateful if you would then provide a more complete description of the problem.

At a minimum, we need:
1. The specific steps or actions you took that caused you to encounter the problem.
2. The URL that showed the problem, and approximate timestamp of any issue.
3. Any OOPS IDs or Sentry IDs that you saw.
4. The behaviour you expected.
5. The behaviour you actually encountered (in as much detail as possible).
6. What attempts were made to reproduce the problem and if they were successful.

Thanks!

Changed in snapstore:
status: New → Incomplete
LukeWH (0-luke) wrote :

This seems to be a problem with the /dev/api/snaps/(snap_id)/metadata endpoint.

What happened:
I got the error "IndexError: tuple index out of range" when trying to save the description field of a snap on snapcraft.io

What I expect:
To be able to save the description field of a snap on snapcraft.i

Steps to reproduce:
1. Visit https://snapcraft.io/snaps
2. Click on a snap (preferably one that isn't public)
3. Change the description to include "{}"
4. Save the change, success!
5. Remove the "{}" from the description
6. Save the change, receive the error "IndexError: tuple index out of range"

Using https://dashboard.snapcraft.io to delete the characters does work, however.

Adam Collard (adam-collard) wrote :

Luke's reproducer is in Sentry as SNAPCRAFT-DASHBOARD-ZN

Changed in snapstore:
status: Incomplete → Confirmed
Changed in software-center-agent:
status: New → Confirmed
Changed in snapstore:
importance: Undecided → High
Changed in software-center-agent:
importance: Undecided → High
assignee: nobody → Adam Collard (adam-collard)
LukeWH (0-luke) wrote :

Different error message, but seems related.

From https://github.com/canonical-websites/snapcraft.io/issues/1161

"Added a } character to the app store description. Now every time we try to update the store entry we see the error ValueError: Single '}' encountered in format string"

Changed in software-center-agent:
status: Confirmed → In Progress
Changed in software-center-agent:
status: In Progress → Fix Committed
Changed in snapstore:
status: Confirmed → Fix Committed
assignee: nobody → Adam Collard (adam-collard)
Changed in snapstore:
status: Fix Committed → Fix Released
Changed in software-center-agent:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.