File dispute not working

Bug #1771767 reported by Thomas Bille on 2018-05-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Snap Store
Undecided
Celso Providelo
Snapcraft
Undecided
Unassigned

Bug Description

# Summary

When registering a snap name that already exists filing a dispute is not working.

# Steps to reproduce

## On API

- Register a snap that already exists
/dev/api/register-name/
{
  "snap_name": "toto"
}

Response:
409 Conflict
{
 "error_list": [{'message': "'toto' is already registered.", 'code': 'already_registered'}]
}

- File a dispute
/dev/api/register-name/
{
  "snap_name": "toto",
  "registrant_comment": "I want this awesome snap name"
}

Response:
409 Conflict
{
 "error_list": [{'message': "'toto' is already registered.", 'code': 'already_registered'}]
}

# Expected behaviour

## On API

- Register a snap that already exists
/dev/api/register-name/
{
  "snap_name": "toto"
}

Response:
409 Conflict
{
 "error_list": [{'message': "'toto' is already registered.", 'code': 'already_registered'}]
}

- File a dispute
/dev/api/register-name/
{
  "snap_name": "toto",
  "registrant_comment": "I want this awesome snap name"
}

Response:
409 Conflict
{
 "error_list": [{'message': "You already registered a claim for 'toto'.", 'code': 'already_claimed'}]
}

Adam Collard (adam-collard) wrote :
Changed in snapstore:
status: New → Incomplete
Thomas Bille (tbmb) wrote :

I updated the description without the dashboard part, I don't why it seemed to work for me yesterday...
So it seems that the problem comes from the API

description: updated
Thomas Bille (tbmb) on 2018-05-17
description: updated
Changed in snapstore:
status: Incomplete → New
Celso Providelo (cprov) on 2018-06-04
Changed in snapstore:
assignee: nobody → Celso Providelo (cprov)
status: New → In Progress
Celso Providelo (cprov) wrote :

The associate MP has landed in staging for tests.

It has dropped the support for 'registrant_comment' field, since it would be only saved in cases it's not relevant at all (when the name is registered). For now, the API does not support filing disputes (reserved or transfer requests), they have to be done via the webUI.

Snapcraft has to grow support for `already_claimed` and `revoked_name` error codes, otherwise it will continue to fallback to "Registration failed." CLI error.

Changed in snapstore:
status: In Progress → Fix Committed
Sergio Schvezov (sergiusens) wrote :

What is the difference between `already_claimed` and these: `reserved_name`, `already_owned` and `already_registered`. Is it that you have claimed it or that someone else has? Link to docs would be nice.

Celso Providelo (cprov) wrote :

Sergio,

Documentation was updated in https://dashboard.staging.snapcraft.io/docs/api/snap.html#register-a-package-name (will eventually reach production)

 * `already_owned` => name is already yours, nothing to be done
 * `already_registered` => registered by someone else, you may file a name-dispute in the web UI
 * `reserved_name` => blacklisted names (debs or special terms), you may file a name-dispute in the web UI
 * `already_claimed` => "... is waiting for review, either because it was a reserved name or already registered by someone else ..."

One tries `snapcraft register foo` and gets either `already_registered` or `reserved_name` error, goes to dashboard (following the error instructions) and file a name-dispute ... goes to bed. Next day, when trying again `snapcraft register foo`, one gets `already_claimed` error.

Celso Providelo (cprov) on 2018-06-11
Changed in snapstore:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers