Cannot upload riscv64 snap

Bug #1884820 reported by Dimitri John Ledkov on 2020-06-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Snap Store Server
Undecided
Unassigned
review-tools
Undecided
Jamie Strandboge

Bug Description

Cannot upload riscv64 snap

https://people.canonical.com/~xnox/uc20/core20_20_riscv64.snap

$ snapcraft push ./core20_20_riscv64.snap
DEPRECATED: The 'push' set of commands have been replaced with 'upload'.
See http://snapcraft.io/docs/deprecation-notices/dn11 for more information.
Preparing to upload 'core20_20_riscv64.snap'.
Install the review-tools from the Snap Store for enhanced checks before uploading this snap.
Pushing 'core20_20_riscv64.snap' [=================================================================] 100%
Processing...|
Error while processing...
The store was unable to accept this snap.
  - architectures: Invalid architecture specified in the manifest: riscv64.

---

separately

review-tools.snap-review ./core20_20_riscv64.snap
Errors
------
 - lint-snap-v2:architecture_valid
 invalid multi architecture: riscv64
./core20_20_riscv64.snap: FAIL

Related branches

description: updated
Daniel Manrique (roadmr) on 2020-06-23
Changed in snapstore-server:
status: New → Confirmed
Changed in review-tools:
status: New → In Progress
assignee: nobody → Jamie Strandboge (jdstrand)
Jamie Strandboge (jdstrand) wrote :

This is committed and released to the 20200623-2050UTC tag.

Changed in review-tools:
status: In Progress → Fix Released
Dimitri John Ledkov (xnox) wrote :

When can I upload riscv64 core20 snap into the store?

Daniel Manrique (roadmr) wrote :

Hi Dimitri,

We need to add the architecture to our database (it's simple, takes a minute) and also need to deploy the review-tools update to the store production servers, it's slightly more involved since we're in the middle of some charm upgrades which are proving tricky.

I'll try to update the bug and notify you when things are ready.

tags: added: id-5ef3b219bc51182c818f9b07
Dimitri John Ledkov (xnox) wrote :

Has the architecture been added?

Have the new review tools been deployed?

Changed in snapstore-server:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers