xdgopenproxy: Outdated github.com/godbus/dbus dependency

Bug #1839498 reported by BobMauchin
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Snappy
Confirmed
Low
Zygmunt Krynicki

Bug Description

Latest github.com/godbus/dbus is incompatible with xdgopenproxy:

```
BUILDSTDERR: ok github.com/# github.com/snapcore/snapd/xdgopenproxy_test [github.com/snapcore/snapd/xdgopenproxy.test]
BUILDSTDERR: ./xdgopenproxy_test.go:50:29: cannot use launcher (type fakeBusObject) as type dbus.BusObject in argument to xdgopenproxy.Launch:
BUILDSTDERR: fakeBusObject does not implement dbus.BusObject (missing AddMatchSignal method)
BUILDSTDERR: ./xdgopenproxy_test.go:64:29: cannot use launcher (type fakeBusObject) as type dbus.BusObject in argument to xdgopenproxy.Launch:
BUILDSTDERR: fakeBusObject does not implement dbus.BusObject (missing AddMatchSignal method)
BUILDSTDERR: ./xdgopenproxy_test.go:80:29: cannot use launcher (type fakeBusObject) as type dbus.BusObject in argument to xdgopenproxy.Launch:
BUILDSTDERR: fakeBusObject does not implement dbus.BusObject (missing AddMatchSignal method)
BUILDSTDERR: ./xdgopenproxy_test.go:93:29: cannot use launcher (type fakeBusObject) as type dbus.BusObject in argument to xdgopenproxy.Launch:
BUILDSTDERR: fakeBusObject does not implement dbus.BusObject (missing AddMatchSignal method)
BUILDSTDERR: ./xdgopenproxy_test.go:103:29: cannot use launcher (type fakeBusObject) as type dbus.BusObject in argument to xdgopenproxy.Launch:
BUILDSTDERR: fakeBusObject does not implement dbus.BusObject (missing AddMatchSignal method)
BUILDSTDERR: ./xdgopenproxy_test.go:119:29: cannot use launcher (type fakeBusObject) as type dbus.BusObject in argument to xdgopenproxy.Launch:
BUILDSTDERR: fakeBusObject does not implement dbus.BusObject (missing AddMatchSignal method)
BUILDSTDERR: error: Bad exit status from /var/tmp/rpm-tmp.Qzs1b0 (%check)
BUILDSTDERR: Bad exit status from /var/tmp/rpm-tmp.Qzs1b0 (%check)
snapcore/snapd/wrappers 0.318s
github.com/snapcore/snapd/xdgopenproxy
```

It would be rice to update xdgopenproxy_test to keep up with upstream github.com/godbus/dbus

Zygmunt Krynicki (zyga)
Changed in snappy:
status: New → Confirmed
Revision history for this message
Zygmunt Krynicki (zyga) wrote :

Patch to make snapd compatible with latest upstream godbus is at https://github.com/snapcore/snapd/pull/7224

I will send the dependency update separately, as it has different concerns regarding landing (dependency packaging, extra testing).

Changed in snappy:
importance: Undecided → Low
assignee: nobody → Zygmunt Krynicki (zyga)
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers