customized dragonboard image cannot complete booting

Bug #1652617 reported by Shuduo Sang on 2016-12-26
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Snappy
Undecided
Unassigned

Bug Description

Install ubuntu-image on Ubuntu 16.04.1:
sudo snap install --devmode --edge ubuntu-image

$ snap list
Name Version Rev Developer Notes
core 16.04.1 641 canonical -
ubuntu-image 0.12+real1 44 canonical devmode

The steps are following:

1,generate model assertion according to the official document https://docs.ubuntu.com/core/en/guides/build-device/image-building for dragonboard 410c.

2, build kernel snap according to http://blog.sergiusens.org/posts/Snapcrafting-a-kernel/

3, build gadget snap from https://github.com/snapcore/dragonboard-gadget (same result if even use lp:~snappy-dev/snappy-hub/snappy-systems)

4, generate customized image with command:
$ sudo /snap/bin/ubuntu-image -d --channel stable --image-size 4G --extra-snaps dragonboard_16.04-0.18_armhf.snap --extra-snaps 96boards-kernel_4.4.0_arm64.snap -o dragonboard-stable.img dragonboard.model

5, flash to TF card and boot up dragonboard.

Expected result is the board boot up to console-conf.

Actual result:

...
[ 6.082575] [drm] No driver support for vblank timestamp query.
[ 6.896780] Console: switching to colour frame buffer device 240x67
[ 6.946930] msm 1a00000.qcom,mdss_mdp: fb0: msm frame buffer device
[ 6.974739] [drm] Initialized msm 1.0.0 20130625 on minor 0
[ 6.977017] qcom-apq8016-sbc 7702000.sound: error getting codec dai name
[ 6.979267] qcom-apq8016-sbc 7702000.sound: Error resolving dai links: -517
[ 6.986383] hctosys: unable to open rtc device (rtc0)
[ 7.000552] ALSA device list:
[ 7.000672] No soundcards found.
[ 7.003259] Freeing unused kernel memory: 996K (ffffffc000d35000 - ffffffc000e2e000)
[ 7.005985] Freeing alternatives memory: 56K (ffffffc000e2e000 - ffffffc000e3c000)
[ 7.058990] random: systemd-udevd urandom read with 7 bits of entropy available
[ 130.349369] random: nonblocking pool is initialized
...

The kernel taking 2 min on random nonblocking pool initialization. Then initrd's script/local-premount taking much longer time and stop at "findfs: unable to resolve 'LABEL=writable'" and exit to busybox shell.

Shuduo Sang (sangshuduo) wrote :

Tried to stitch image with customized kernel and model assertion but use official gadget from store. The booting has same issue. Then tried to stitch image with customized model assertion but use official kernel and official gadget snap. Then the booting works very well. So the kernel is the root cause.

Rex Tsai (chihchun) wrote :

1. add debug in kernel boot cmdline should porivde more information for deubgging.
2. Please use parted to print out the partition layout of the image, to ensure the label is correctly written.
3. Please provide the kernel (.config) or kernel snap config for verify the kernel options. The system hangs initram disk, most likely could be an issue on missing some required kernel options.

Changed in snappy:
status: New → Incomplete
Matta Jayaram (jayarammatta) wrote :

     I am also getting the same error with Intel(R) Celeron(R) CPU N3450 @ 1.10GHz.
   Builded Cutsom Ubuntu Core image with Custom gadget & kernel snaps .Flashed image to the USB pendrive using Startup Disk Creator tool.
   While booting Ubuntu core from USB Stick we are getting
 tsc clocksource switched,
Begin:Running /scripts/local-premount ... [
findfs: unable to resolve 'LABEL=writable and finally it was freezing at (initramfs).

 ---please Look at below Screen shot---

Plese suggest on it.

With Regard's,
Jayaram Matta,
+91-9493952323

Launchpad Janitor (janitor) wrote :

[Expired for Snappy because there has been no activity for 60 days.]

Changed in snappy:
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers