Installing snapd on 14.04.5 desktop downgrades xorg et al.

Bug #1650389 reported by Thomas Voß
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Snappy
Invalid
Critical
Unassigned
systemd (Ubuntu)
Won't Fix
Critical
Thomas Voß
Trusty
Won't Fix
Critical
Thomas Voß

Bug Description

When trying to install the latest snapd on a 14.04.5 desktop image, the installation of systemd (as a dependency of snapd) triggers a whole bunch of downgrades as systemd-shim is removed and replaced with systemd.

We have to adjust the packaging such that installation of systemd does not trigger such behavior for packages depending on systemd-shim in trusty.

Tags: 14.04
Michael Vogt (mvo)
Changed in snappy:
status: New → Confirmed
importance: Undecided → Critical
Changed in systemd (Ubuntu):
importance: Undecided → Critical
status: New → Confirmed
Revision history for this message
Steve Langasek (vorlon) wrote :

I do not believe there is any path to successfully install snapd on a 14.04 desktop system. Only one of systemd and systemd-shim can own the systemd dbus services; systemd doesn't implement them in a way that will work with upstart as pid1, which means we need systemd-shim to own them so that the desktop consumers of the services will function; and it's intrusive surgery to make systemd work without registering them.

This was a known limitation when the SRU went through, and it was allowed because the understood target for snapd on 14.04 was server/cloud environments, not desktops. Has that changed?

Changed in systemd (Ubuntu):
status: Confirmed → Incomplete
Revision history for this message
Mark Shuttleworth (sabdfl) wrote : Re: [Bug 1650389] Re: Installing snapd on 14.04.5 desktop downgrades xorg et al.

On 15/12/16 17:25, Steve Langasek wrote:
> This was a known limitation when the SRU went through, and it was
> allowed because the understood target for snapd on 14.04 was
> server/cloud environments, not desktops. Has that changed?

It's unexpected for me, and will be substantially difficult to message
("install this but not on a desktop"). So I think we need to press on
this to understand it better. We do want snaps on 14.04, its a key part
of the value we're offering, but we can't make that a choice that
negatively impacts a desktop.

Mark

Changed in systemd (Ubuntu):
assignee: nobody → Thomas Voß (thomas-voss)
status: Incomplete → Confirmed
Changed in systemd (Ubuntu Trusty):
assignee: nobody → Thomas Voß (thomas-voss)
status: New → Confirmed
importance: Undecided → Critical
Changed in systemd (Ubuntu):
status: Confirmed → Fix Committed
Changed in systemd (Ubuntu Trusty):
status: Confirmed → Fix Committed
Revision history for this message
Zygmunt Krynicki (zyga) wrote :

I'm marking this as invalid as it seems to be a bug specific to systemd packaging, not to snapd per se.

Changed in snappy:
status: Confirmed → Invalid
Revision history for this message
Dan Streetman (ddstreet) wrote :

please reopen if this is still an issue

Changed in systemd (Ubuntu Trusty):
status: Fix Committed → Won't Fix
Changed in systemd (Ubuntu):
status: Fix Committed → Won't Fix
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers