console-conf wifi only setup on pi3 beta3 image not possible

Bug #1632387 reported by Oliver Grawert on 2016-10-11
This bug report is a duplicate of:  Bug #1696162: brcmfmac does not support unbinding. Edit Remove
42
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Snappy
High
Unassigned
subiquity (Ubuntu)
Undecided
Unassigned

Bug Description

using the pi3 beta3 image for testing there is no way to make use of the wlan device in console-conf, network setup always times out, one has to use a wired network to do the first setup.

Michael Hudson-Doyle (mwhudson) wrote :

This did work at some point, didn't it? Once you've configured with wired, does the wlan interface actually work?

Oliver Grawert (ogra) wrote :

no, it never worked on the pi3 ... it works fine on the dragonboard where we only have a wlan interface, it is either caused by having two interfaces or it is an actual driver bug of the pi3 wlan driver not being set up correctly at the point console-conf runs (wlan works fine if you configure it manually later)

Leo Arias (elopio) on 2016-11-02
Changed in snappy:
status: New → Confirmed
importance: Undecided → High
Leo Arias (elopio) wrote :

Confirmed in the image from today:

$ snap list
Name Version Rev Developer Notes
core 16.04.1 385 canonical -
pi2-kernel 4.4.0-1030-3 22 canonical -
pi3 16.04-0.5 6 canonical -
$ snap version
snap 2.17
snapd 2.17
series 16

It is also happening that with the current candidate image.

I also saw that when I go through the networking screen without any configuration and then press cancel, the networking screen is not showing the wlan anymore, it just shows the ethernet connection.

Attached is the image that I see with the timeout error.

Ken Martin (papakpmartin) wrote :

Still happening in http://cdimage.ubuntu.com/ubuntu-core/16/stable/current/ubuntu-core-16-pi3.img.xz.

After I "Press enter to configure" and after I set up my Wi-Fi access point and click "Done", it begins "Applying network config", stops at 66%, apparently loses wlan0 (it disappears from the screen), and reports "brcmf_cfg80211_reg_notifier: not a ISO3166 code".

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in subiquity (Ubuntu):
status: New → Confirmed
Guy Taylor (thebiggerguy) wrote :

I re-ran "console-conf" via eth and set up the WiFi again. It again failed with the above UI issues and ifconfig showed no connection. However after restarting the device it was connected to the WiFi.

I am running:
uname -a
Linux localhost.localdomain 4.4.0-1051-raspi2 #58-Ubuntu SMP Fri Mar 24 13:48:21 UTC 2017 armv7l armv7l armv7l GNU/Linux

snap list
Name Version Rev Developer Notes
core 16-2.26.4 2086 canonical -
pi2-kernel 4.4.0-1051.52 29 canonical -
pi3 16.04-0.5 6 canonical -

On the "brcmf_cfg80211_reg_notifier" issue there is https://bugs.launchpad.net/raspbian/+bug/1646961 and https://bugzilla.kernel.org/show_bug.cgi?id=189581

Francis Ginther (fginther) wrote :

I can confirm that with the http://cdimage.ubuntu.com/ubuntu-core/16/stable/20170621/ubuntu-core-16-pi3.img.xz, wlan-only setup does work (at least once) after restarting the device. Basically:

1) Boot with http://cdimage.ubuntu.com/ubuntu-core/16/stable/20170621/ubuntu-core-16-pi3.img.xz
2) Configure wlan device with credentials
3) Attempt to setup, the setup will timeout and fail
4) Restart (ctrl-alt-delete)
5) On the restart, the wlan will be configured with the wifi credentials. This time, continuing on with setup worked.

This could have just been luck. I have not yet attempted to reproduce it.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.