console-conf wlan race on pi3

Bug #1624322 reported by Oliver Grawert on 2016-09-16
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Snappy
Undecided
Unassigned
subiquity (Ubuntu)
Undecided
Unassigned

Bug Description

when booting a pi3 i do not get offered wlan0 in console-conf ...
rebooting without configuring gets me the interface though but configuration times out when trying to configure it.
there seems to be a race between the interface coming up and console-conf starting.
probably caused by the fact that starting the python UI process takes up to 5-10min with the board constantly showing the "to high load" indicator on screen (the rainbow colored square on top right of a HDMI attached monitor).

configuring the board with a wired network and rebooting shows wlan0 just fine in /proc/net/dev after configuration and the interface can be manually configured using "iw" and "dhclient" manually.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in subiquity (Ubuntu):
status: New → Confirmed
Oliver Grawert (ogra) wrote :

also, configuring wired, then ssh'ing into teh working device and running "sudo console-conf" lets you reconfigure the board for wlan (disabling eth0) just fine, this only seems to happen on first boot and only if no network cable is plugged in.

this might be related to bug 1637505

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package subiquity - 0.0.24

---------------
subiquity (0.0.24) zesty; urgency=medium

  * Rework network model and UI significantly, using rtnetlink nl80211 events
    to provide a live view of the state of the network as it changes.
    (LP: #1627031, #1624322, #1637153)
  * Show friendly message instead of getty when only ssh login is possible.
    (LP: #1639543)
  * Hide keypresses while in the "press enter to configure" screen.
    (LP: #1639917)
  * Give a hint on how to create a store account. (LP: #1639799)

 -- Michael Hudson-Doyle <email address hidden> Mon, 07 Nov 2016 16:43:06 +1300

Changed in subiquity (Ubuntu):
status: Confirmed → Fix Released
Changed in snappy:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers