GL interfaces seem wedged for Krita on nvidia

Bug #1588192 reported by Mark Shuttleworth on 2016-06-02
110
This bug affects 17 people
Affects Status Importance Assigned to Milestone
Snappy
Critical
Unassigned
nvidia-graphics-drivers-304 (Ubuntu)
Critical
Alberto Milone
Xenial
Critical
Alberto Milone
nvidia-graphics-drivers-340 (Ubuntu)
Critical
Alberto Milone
Xenial
Critical
Alberto Milone
nvidia-graphics-drivers-361 (Ubuntu)
Critical
Alberto Milone
Xenial
Critical
Alberto Milone

Bug Description

Krita snap segfaults. I'm running nvidia proprietary drivers on Dell XPS 15.

mark@mark-XPS-15-9550:~$ snap install krita
97.84 MB / 97.84 MB [=====================================================================================================================================================================================] 100.00 % 362.82 KB/s

Name Version Rev Developer
krita 3.0-snap10 1 krita
mark@mark-XPS-15-9550:~$ krita
QCoreApplication::arguments: Please instantiate the QApplication object first
krita.lib.pigment: Compiled for arch: ::Vc::AVXImpl
krita.lib.pigment: Features supported:
krita.lib.pigment: "SSE2" --- yes
krita.lib.pigment: "SSSE3" --- yes
krita.lib.pigment: "SSE4.1" --- yes
krita.lib.pigment: "AVX " --- yes
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
Segmentation fault (core dumped)
mark@mark-XPS-15-9550:~$

Michael Vogt (mvo) on 2016-06-02
Changed in snappy:
status: New → In Progress
importance: Undecided → Critical
Michael Vogt (mvo) wrote :

This adds a systemd bind mount unit that will automatically make the right nvidia opengl library available from classic to the snaps. This will have to go to yakkety and xenial-updates.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nvidia-graphics-drivers-361 (Ubuntu):
status: New → Confirmed
Michael Vogt (mvo) wrote :

There is actually nothing for snapd itself to do here, its doing the right thing as soon as the bind mount unit is available. I keep the bug open for easier tracking for us.

Changed in nvidia-graphics-drivers-361 (Ubuntu):
importance: Undecided → Critical
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nvidia-graphics-drivers-361 (Ubuntu Xenial):
status: New → Confirmed

This of course is a problem for all NVIDIA drivers not only the 361. So the other packages also need to be patched.

Michael Vogt (mvo) on 2016-06-02
Changed in nvidia-graphics-drivers-361 (Ubuntu Xenial):
importance: Undecided → Critical
status: Confirmed → In Progress
Changed in nvidia-graphics-drivers-361 (Ubuntu):
status: Confirmed → In Progress
tags: added: patch
dinamic (dinamic6661) wrote :

same here with nvidia 340.96 :'(

dinamic (dinamic6661) wrote :

krita
QCoreApplication::arguments: Please instantiate the QApplication object first
krita.lib.pigment: Compiled for arch: ::Vc::SSE2Impl
krita.lib.pigment: Features supported:
krita.lib.pigment: "SSE2" --- yes
krita.lib.pigment: "SSSE3" --- no
krita.lib.pigment: "SSE4.1" --- no
krita.lib.pigment: "AVX " --- no
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
Unrecognized OpenGL version
Unrecognized OpenGL version

Changed in nvidia-graphics-drivers-361 (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
Changed in nvidia-graphics-drivers-361 (Ubuntu Xenial):
assignee: nobody → Alberto Milone (albertomilone)
Changed in nvidia-graphics-drivers-340 (Ubuntu):
status: New → In Progress
Changed in nvidia-graphics-drivers-340 (Ubuntu Xenial):
status: New → In Progress
Changed in nvidia-graphics-drivers-340 (Ubuntu):
importance: Undecided → Critical
Changed in nvidia-graphics-drivers-340 (Ubuntu Xenial):
importance: Undecided → Critical
Changed in nvidia-graphics-drivers-304 (Ubuntu):
status: New → In Progress
Changed in nvidia-graphics-drivers-304 (Ubuntu Xenial):
status: New → In Progress
Changed in nvidia-graphics-drivers-304 (Ubuntu):
importance: Undecided → Critical
Changed in nvidia-graphics-drivers-304 (Ubuntu Xenial):
importance: Undecided → Critical
Changed in nvidia-graphics-drivers-304 (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
Changed in nvidia-graphics-drivers-304 (Ubuntu Xenial):
assignee: nobody → Alberto Milone (albertomilone)
Changed in nvidia-graphics-drivers-340 (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
Changed in nvidia-graphics-drivers-340 (Ubuntu Xenial):
assignee: nobody → Alberto Milone (albertomilone)

Thanks for taking this on Alberto!

Interestingly, with FreeCAD I see an error but it still seems to load
and run!

mark@mark-XPS-15-9550:~$ freecad.FreeCAD
FreeCAD 0.17, Libs: 0.17R7744 (Git)
© Juergen Riegel, Werner Mayer, Yorik van Havre 2001-2015
  ##### #### ### ####
  # # # # # #
  # ## #### #### # # # # #
  #### # # # # # # # ##### # #
  # # #### #### # # # # #
  # # # # # # # # # ## ## ##
  # # #### #### ### # # #### ## ## ##

GLib-GIO-Message: Using the 'memory' GSettings backend. Your settings
will not be saved or shared with other applications.
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast

Oliver Grawert (ogra) wrote :

freecad doesnt use any GL to draw the UI, you will simply not have full functionality (rendering etc) but the app will run

Alberto Milone (albertomilone) wrote :

@Mark: that means that either the system or (more likely) the app is using software rendering. Maybe that is enough for the app, although it should be a little slower. Soon this will be working with full acceleration :)

@Michael: thanks for the patch! I made a little change, so that the .mount file is generated by a template. Also I am porting the change to all the other nvidia drivers, so that this bug can be fixed for all users.

Alberto Milone (albertomilone) wrote :

I have applied the changes to 361 and 340. The old 304 legacy driver is the only one remaining, as it will require further changes (a switch from cdbs to debhelper) in order to apply Michael's patch. I promise I am going to fix 304 soon.

In the meantime we can proceed with the SRU for 361 and 340, as they cover most modern NVIDIA GPUs.

Hello Mark, or anyone else affected,

Accepted nvidia-graphics-drivers-361 into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/nvidia-graphics-drivers-361/361.45.11-0ubuntu0.16.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in nvidia-graphics-drivers-361 (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed
Timo Aaltonen (tjaalton) wrote :

Hello Mark, or anyone else affected,

Accepted nvidia-graphics-drivers-340 into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/nvidia-graphics-drivers-340/340.96-0ubuntu3.16.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in nvidia-graphics-drivers-340 (Ubuntu Xenial):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nvidia-graphics-drivers-361 - 361.45.11-0ubuntu2

---------------
nvidia-graphics-drivers-361 (361.45.11-0ubuntu2) yakkety; urgency=medium

  [ Michael Vogt ]
  * debian/rules, debian/templates/control.in,
    debian/templates/nvidia-graphics-drivers.dirs.in,
    debian/templates/nvidia-graphics-drivers.install.in,
    debian/templates/nvidia-graphics-drivers.postinst.in,
    debian/templates/var-lib-snapd-lib-gl.mount.in:
    - Add bind mount unit for snappy (LP: #1588192).

 -- Alberto Milone <email address hidden> Fri, 03 Jun 2016 10:01:03 +0200

Changed in nvidia-graphics-drivers-361 (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nvidia-graphics-drivers-340 - 340.96-0ubuntu5

---------------
nvidia-graphics-drivers-340 (340.96-0ubuntu5) yakkety; urgency=medium

  [ Michael Vogt ]
  * debian/rules, debian/templates/control.in,
    debian/templates/nvidia-graphics-drivers.dirs.in,
    debian/templates/nvidia-graphics-drivers.install.in,
    debian/templates/nvidia-graphics-drivers.postinst.in,
    debian/templates/var-lib-snapd-lib-gl.mount.in:
    - Add bind mount unit for snappy (LP: #1588192).

 -- Alberto Milone <email address hidden> Fri, 03 Jun 2016 10:20:22 +0200

Changed in nvidia-graphics-drivers-340 (Ubuntu):
status: In Progress → Fix Released
dinamic (dinamic6661) wrote :

TADA! http://i.imgur.com/yVIJqWi.png

just updated (nvidia-graphics-drivers-340) and krita runs now! yay

I have 361.45.11-0ubuntu0.16.04.1 and am still seeing:

mark@mark-XPS-15-9550:~$ krita
QCoreApplication::arguments: Please instantiate the QApplication object
first
krita.lib.pigment: Compiled for arch: ::Vc::AVXImpl
krita.lib.pigment: Features supported:
krita.lib.pigment: "SSE2" --- yes
krita.lib.pigment: "SSSE3" --- yes
krita.lib.pigment: "SSE4.1" --- yes
krita.lib.pigment: "AVX " --- yes
XmbTextListToTextProperty result code -2
QOpenGLFunctions created with non-current context
Segmentation fault (core dumped)

I think this is different (no swrast) but still not fixed :(

Alberto Milone (albertomilone) wrote :

@Mark: can you attach your /var/log/gpu-manager.log , please?

dinamic (dinamic6661) wrote :

not Mark but here's my gpu-manager.log (nvidia_340) - krita is working for me

log_file: /var/log/gpu-manager.log
last_boot_file: /var/lib/ubuntu-drivers-common/last_gfx_boot
new_boot_file: /var/lib/ubuntu-drivers-common/last_gfx_boot
can't access /run/u-d-c-fglrx-was-loaded file
Looking for fglrx modules in /lib/modules/4.4.0-23-generic/updates/dkms
Looking for nvidia modules in /lib/modules/4.4.0-23-generic/updates/dkms
Found nvidia module: nvidia_340_uvm.ko
Is nvidia loaded? yes
Was nvidia unloaded? no
Is nvidia blacklisted? no
Is fglrx loaded? no
Was fglrx unloaded? no
Is fglrx blacklisted? no
Is intel loaded? no
Is radeon loaded? no
Is radeon blacklisted? no
Is amdgpu loaded? no
Is amdgpu blacklisted? no
Is nouveau loaded? no
Is nouveau blacklisted? yes
Is fglrx kernel module available? no
Is nvidia kernel module available? yes
Vendor/Device Id: 10de:402
BusID "PCI:4@0:0:0"
Is boot vga? yes
Skipping "/dev/dri/card0", driven by "nvidia-drm"
Skipping "/dev/dri/card0", driven by "nvidia-drm"
Skipping "/dev/dri/card0", driven by "nvidia-drm"
Skipping "/dev/dri/card0", driven by "nvidia-drm"
Does it require offloading? no
last cards number = 1
Has amd? no
Has intel? no
Has nvidia? yes
How many cards? 1
Has the system changed? No
main_arch_path x86_64-linux-gnu, other_arch_path i386-linux-gnu
Current alternative: /usr/lib/nvidia-340/ld.so.conf
Current core alternative: (null)
Current egl alternative: /usr/lib/x86_64-linux-gnu/mesa-egl/ld.so.conf
Is nvidia enabled? yes
Is nvidia egl enabled? no
Is fglrx enabled? no
Is mesa enabled? no
Is mesa egl enabled? yes
Is pxpress enabled? no
Is prime enabled? no
Is prime egl enabled? no
Is nvidia available? yes
Is nvidia egl available? no
Is fglrx available? no
Is fglrx-core available? no
Is mesa available? yes
Is mesa egl available? yes
Is pxpress available? no
Is prime available? yes
Is prime egl available? no
Single card detected
Driver is already loaded and enabled
Nothing to do
No change - nothing to do

I'm also on nvidia_340 and Krita is working now.

Oliver Grawert (ogra) wrote :

Looks like there is breakage caused by thus change, see bug #1589006

Mark Shuttleworth (sabdfl) wrote :

Yes, can we up this to critical, please?

I'm wondering if the GLVND which is present in 361 drivers and not in 340 isn't the reason for all those problems.

https://devtalk.nvidia.com/default/topic/915640/multiple-glx-client-libraries-in-the-nvidia-linux-driver-installer-package/

Alberto Milone (albertomilone) wrote :

I'll look into the problem and make sure it's fixed in 361 for good.

As a part of the Stable Release Updates quality process a search for Launchpad bug reports using the version of nvidia-graphics-drivers-340 from xenial-proposed was performed and bug 1589273 was found. Please investigate this bug report to ensure that a regression will not be created by this SRU. In the event that this is not a regression remove the "verification-failed" tag from this bug report and add the tag "bot-stop-nagging" to bug 1589273 (not this bug). Thanks!

tags: added: verification-failed
Alberto Milone (albertomilone) wrote :

Installing the snap from Krita's website, and using the 361 driver from proposed works fine here. See the attached screenshot.

There is no snap package on Krita website they only provide appimages.

Also the current snap for Krita is 3.0-snap12. That's 3rd revision of that package.

Alberto Milone (albertomilone) wrote :

True, I got the link from Krita's release notes on the website, but that pointed to the appstore:
https://krita.org/item/krita-3-0-released/

As a part of the Stable Release Updates quality process a search for Launchpad bug reports using the version of nvidia-graphics-drivers-361 from xenial-proposed was performed and bug 1589377 was found. Please investigate that bug report to ensure that a regression will not be created by this SRU. In the event that bug 1589377 is not a regression, tag it "bot-stop-nagging". Thanks!

Pavak Paul (pavakatubuntu) wrote :

It says Fix released for 361, I am running Nvidia 361.42, just performed a system update (dist-upgrade) but still can't run krita. here is the terminal output:
pavak@pavak-desktop-os1:~$ krita
QCoreApplication::arguments: Please instantiate the QApplication object first
krita.lib.pigment: Compiled for arch: ::Vc::AVXImpl
krita.lib.pigment: Features supported:
krita.lib.pigment: "SSE2" --- yes
krita.lib.pigment: "SSSE3" --- yes
krita.lib.pigment: "SSE4.1" --- yes
krita.lib.pigment: "AVX " --- yes
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
Unrecognized OpenGL version
Unrecognized OpenGL version

Alberto Milone (albertomilone) wrote :

I spoke with Michael, and we are going to reject the patch for the nvidia packages in xenial-proposed (already reverted in Yakkety), as he has a better plan now (so that we don't run into LP: #1589006).

For this reason I am closing the tasks for the nvidia drivers for now.

Changed in nvidia-graphics-drivers-340 (Ubuntu):
status: Fix Released → Invalid
Changed in nvidia-graphics-drivers-340 (Ubuntu Xenial):
status: Fix Committed → Invalid
Changed in nvidia-graphics-drivers-361 (Ubuntu):
status: Fix Released → Invalid
Changed in nvidia-graphics-drivers-361 (Ubuntu Xenial):
status: Fix Committed → Invalid
Pavak Paul (pavakatubuntu) wrote :

Before these get fixed, is there any way for us to use Krita 3 in Ubuntu? Maybe a PPA or something (non snappy) like that?

Martin Pitt (pitti) wrote :

I removed nvidia-graphics-drivers-340 340.96-0ubuntu3.16.04.1 from xenial-proposed.

tags: removed: verification-failed verification-needed
Florian Boucault (fboucault) wrote :

Any news on this one?

Florian Boucault (fboucault) wrote :

In my GL using app I had to add the bind mount /var/lib/snapd/lib/gl to LD_LIBRARY_PATH for it to work with the nVidia proprietary driver.
I proposed that workaround to snapcraft-desktop-helpers: https://github.com/ubuntu/snapcraft-desktop-helpers/pull/28

Changed in nvidia-graphics-drivers-340 (Ubuntu):
status: Invalid → Won't Fix
Changed in nvidia-graphics-drivers-361 (Ubuntu Xenial):
status: Invalid → Won't Fix
Changed in nvidia-graphics-drivers-361 (Ubuntu):
status: Invalid → Won't Fix
Changed in nvidia-graphics-drivers-340 (Ubuntu Xenial):
status: Invalid → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments