libgl not found on nvidia machines (so far)

Bug #1574851 reported by kevin gunn
This bug affects 11 people
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers-361 (Ubuntu)

Bug Description

So I've just had 2 recent complaints on libgl not being found on nvidia.
and on IRC

I cannot determine if anyone has had success running one of the desktop-example apps from the store on an nvidia gpu machine.
I asked Alberto Aguirre on the mir team (who has a nvidia gpu) to try SDoC and install the ubuntu-clock-app from the store - he confirms seeing the exact same issue, he can be questioned if debug help is needed.

Note, from an engagement on IRC earlier, the person confirmed that even rebuilding the clock snap locally and sideloading did not address the issue.

Revision history for this message
Michael Vogt (mvo) wrote :

We will need to ship a systemd mount unit in the nvidia driver that sets up a bind mount from /usr/lib/nvidia-361 to /var/lib/snapd/lib/gl/

Changed in snappy:
status: New → Triaged
importance: Undecided → Critical
milestone: none → sru-1
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nvidia-graphics-drivers-361 (Ubuntu):
status: New → Confirmed
Michael Vogt (mvo)
Changed in snappy:
milestone: sru-1 → sru-2
Revision history for this message
Zygmunt Krynicki (zyga) wrote :

Dear reporter.

Can you please share the following information:

 - version of snapd and snap-confine (you can check with "apt-cache policy snap-confine")
 - make and model of the GPU you are using
 - the installed driver packages, you can quickly find this with "dpkg --get-selections | grep nvidia")
 - if the snap is public, name and revision of the snap you've tried ("snap list" shows the revision).


Revision history for this message
Alberto Aguirre (albaguirre) wrote :

apt-cache policy snapd
  Installed: 2.0.9
  Candidate: 2.0.9
  Version table:
 *** 2.0.9 500
        500 xenial-updates/main amd64 Packages

apt-cache policy snap-confine
N: Unable to locate package snap-confine

dpkg --get-selections | grep nvidia
nvidia-361 install
nvidia-opencl-icd-361 install
nvidia-prime install
nvidia-settings install

snap: ubuntu-clock-app version: 3.6+snap3, rev: 5

Running it results in:

libGL error: No matchings fbConfigs or visuals found
libGL error: failed to load driver: swrast
Unrecognized OpenGL version
Unrecognized OpenGL version

Revision history for this message
Zygmunt Krynicki (zyga) wrote :

Thank you for completing this. I think this problem may go away entirely with snapd 2.0.10 and snap-confine 1.0.34 that are currently in xenial-proposed.

Revision history for this message
Alberto Aguirre (albaguirre) wrote :

I have snapd 2.0.10 now, still ubuntu-clock-app does not start

Revision history for this message
Diego Estévez (dgmvecuador) wrote :

The ubuntu-clock-app from the repository has a bug, but you can build it using snapcraft from this github:

Even rebuilding, you will have the same problem, but there is a workaround, copy all files from /usr/lib/nvidia-xxx to /var/lib/snapd/lib/gl/.

This workaround even work with krita.

Revision history for this message
Bill Filler (bfiller) wrote :

I can also confirm with snapd 2.0.10 that I get the same gl errors so this is not fixed.
Also tried the workaround, copy all files from /usr/lib/nvidia-xxx to /var/lib/snapd/lib/gl/ and restarted snapd and now things are working.

Revision history for this message
Zygmunt Krynicki (zyga) wrote :

This is probably a duplicate of 1615248 that is now fixed upstream.

Revision history for this message
Neil McPhail (njmcphail) wrote :

I do not think this is a duplicate of bug #1615248, as removing the dangling symlinks does not fix this issue for me.

Revision history for this message
ike (ikeahloe) wrote :

This also affects the Shotcut snap. *Might* also be why the blender-tpaw build is suboptimal and can't take advantage of GPUs.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.