snapd crashes on slot disconnection

Bug #1571497 reported by Simon Fels
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Snappy
Medium
Zygmunt Krynicki

Bug Description

When trying to disconnect a slot

ubuntu@localhost:~$ sudo ./snap-1 interfaces
Slot Plug
network-manager:service network-manager:nmcli
ubuntu@localhost:~$ sudo ./snap-1 disconnect network-manager:service

the following crash appears with snapd

simon@nirvana ~/Work/ubuntu/snappy/devtools (master*) $ ./refresh-bits --pc run-snapd
Running snapd (use sudo snap to talk to it)
Warning: Permanently added '[localhost]:8022' (ECDSA) to the list of known hosts.
Listening on /run/snapd.socket as 3.
Communication attempt on fd 3.
Execing ./snapd (./snapd)
panic: runtime error: invalid memory address or nil pointer dereference
[signal 0xb code=0x1 addr=0x0 pc=0x5dd4bf]

goroutine 12 [running]:
panic(0x97b940, 0xc82000a0b0)
 /usr/lib/go-1.6/src/runtime/panic.go:464 +0x3e6
github.com/ubuntu-core/snappy/overlord/ifacestate.(*InterfaceManager).doDisconnect(0xc8200e7280, 0xc8200c9880, 0xc8201482d0, 0x0, 0x0)
 /home/simon/Work/ubuntu/snappy/work/src/github.com/ubuntu-core/snappy/overlord/ifacestate/ifacemgr.go:550 +0x28f
github.com/ubuntu-core/snappy/overlord/ifacestate.(*InterfaceManager).(github.com/ubuntu-core/snappy/overlord/ifacestate.doDisconnect)-fm(0xc8200c9880, 0xc8201482d0, 0x0, 0x0)
 /home/simon/Work/ubuntu/snappy/work/src/github.com/ubuntu-core/snappy/overlord/ifacestate/ifacemgr.go:65 +0x42
github.com/ubuntu-core/snappy/overlord/state.(*TaskRunner).run.func1(0x0, 0x0)
 /home/simon/Work/ubuntu/snappy/work/src/github.com/ubuntu-core/snappy/overlord/state/taskrunner.go:103 +0x69
gopkg.in/tomb%2ev2.(*Tomb).run(0xc8201482d0, 0xc820148300)
 /home/simon/Work/ubuntu/snappy/work/src/gopkg.in/tomb.v2/tomb.go:153 +0x21
created by gopkg.in/tomb%2ev2.(*Tomb).Go
 /home/simon/Work/ubuntu/snappy/work/src/gopkg.in/tomb.v2/tomb.go:149 +0x131

This is with the just release snappy v2.0.

Revision history for this message
Zygmunt Krynicki (zyga) wrote :

This is caused by partial support of abbreviated connect/disconnect forms. For now please spell out the full form "$ snap disconnect snap:plug snap:slot"

Changed in snappy:
assignee: nobody → Zygmunt Krynicki (zyga)
status: New → Confirmed
Zygmunt Krynicki (zyga)
Changed in snappy:
status: Confirmed → In Progress
Revision history for this message
Zygmunt Krynicki (zyga) wrote :
Michael Vogt (mvo)
Changed in snappy:
importance: Undecided → Medium
milestone: none → sru-1
Michael Vogt (mvo)
Changed in snappy:
status: In Progress → Fix Committed
status: Fix Committed → Triaged
milestone: sru-1 → sru-2
Zygmunt Krynicki (zyga)
Changed in snappy:
status: Triaged → In Progress
Simon Fels (morphis)
Changed in snappy:
status: In Progress → Fix Released
Revision history for this message
Zygmunt Krynicki (zyga) wrote :

I don't believe this is fixed yet

Changed in snappy:
status: Fix Released → In Progress
Zygmunt Krynicki (zyga)
Changed in snappy:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers