autopkg tests fail on armhf and s390x

Bug #1569478 reported by Daniel Holbach on 2016-04-12
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Snappy
High
Unassigned

Bug Description

autopkg tests fail on armhf and s390x:

ARMHF: https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-xenial/xenial/armhf/s/snapd/20160412_170023@/log.gz

adt-run [16:58:18]: test integrationtests: [-----------------------
Installing godeps
Obtaining dependencies
update github.com/mvo5/goconfigparser failed; trying to fetch newer version
github.com/mvo5/goconfigparser now at 26426272dda20cc76aa1fa44286dc743d2972fe8
update github.com/gorilla/websocket failed; trying to fetch newer version
github.com/gorilla/websocket now at 234959944d9cf05229b02e8b386e5cffe1e4e04a
update github.com/gorilla/mux failed; trying to fetch newer version
github.com/gorilla/mux now at ee1815431e497d3850809578c93ab6705f1a19f7
update github.com/gorilla/context failed; trying to fetch newer version
github.com/gorilla/context now at 1c83b3eabd45b6d76072b66b746c20815fb2872d
update github.com/mvo5/uboot-go failed; trying to fetch newer version
github.com/mvo5/uboot-go now at 361f6ebcbb54f389d15dc9faefa000e996ba3e37
update golang.org/x/crypto failed; trying to fetch newer version
golang.org/x/crypto now at 60052bd85f2d91293457e8811b0cf26b773de469
update github.com/cheggaaa/pb failed; trying to fetch newer version
github.com/cheggaaa/pb now at e8c7cc515bfde3e267957a3b110080ceed51354e
update github.com/gosexy/gettext failed; trying to fetch newer version
github.com/gosexy/gettext now at 98b7b91596d20b96909e6b60d57411547dd9959c
update github.com/jessevdk/go-flags failed; trying to fetch newer version
github.com/jessevdk/go-flags now at 6b9493b3cb60367edd942144879646604089e3f7
update github.com/kr/pty failed; trying to fetch newer version
github.com/kr/pty now at 05017fcccf23c823bfdea560dcc958a136e54fb7
update github.com/peterh/liner failed; trying to fetch newer version
github.com/peterh/liner now at 1bb0d1c1a25ed393d8feb09bab039b2b1b1fbced
update gopkg.in/tomb.v2 failed; trying to fetch newer version
gopkg.in/tomb.v2 now at 14b3d72120e8d10ea6e6b7f87f7175734b1faab8
update gopkg.in/yaml.v2 failed; trying to fetch newer version
gopkg.in/yaml.v2 now at 49c95bdc21843256fb6c4e0d370a05f24a0bf213
update github.com/coreos/go-systemd failed; trying to fetch newer version
github.com/coreos/go-systemd now at f743bc15d6bddd23662280b4ad20f7c874cdd5ad
update gopkg.in/check.v1 failed; trying to fetch newer version
gopkg.in/check.v1 now at 64131543e7896d5bcc6bd5a76287eb75ea96c673
update github.com/testing-cabal/subunit-go failed; trying to fetch newer version
github.com/testing-cabal/subunit-go now at 00b258565a5cf3adaa24b68d31c9e6ec3d2cdbe7
update golang.org/x/net failed; trying to fetch newer version
golang.org/x/net now at 3b90a77d2885fb0429e8a21ab72fc73ca6f8b401
update gopkg.in/tylerb/graceful.v1 failed; trying to fetch newer version
gopkg.in/tylerb/graceful.v1 now at 48afeb21e2fcbcff0f30bd5ad6b97747b0fae38e
sudo systemctl stop snappy-autopilot.timer
sudo: no tty present and no askpass program specified
panic: runtime error: invalid memory address or nil pointer dereference
[signal 0xb code=0x1 addr=0x0 pc=0x142e74]

goroutine 1 [running]:
panic(0x4d9d38, 0x10928030)
 /usr/lib/go-1.6/src/runtime/panic.go:464 +0x330
gopkg.in/check%2ev1.(*methodType).PC(0x0, 0x1593fc)
 /tmp/tmp.WLQdFV1s5S/src/gopkg.in/check.v1/check.go:59 +0x1c
gopkg.in/check%2ev1.(*C).logCaller(0x1099a140, 0x3)
 /tmp/tmp.WLQdFV1s5S/src/gopkg.in/check.v1/check.go:275 +0x7c
gopkg.in/check%2ev1.(*C).internalCheck(0x1099a140, 0x537070, 0x6, 0x520d30, 0x109c0d50, 0xb545c328, 0x1096e1d8, 0x10949eb0, 0x0, 0x1, ...)
 /tmp/tmp.WLQdFV1s5S/src/gopkg.in/check.v1/helpers.go:216 +0xba8
gopkg.in/check%2ev1.(*C).Assert(0x1099a140, 0x520d30, 0x109c0d50, 0xb545c328, 0x1096e1d8, 0x10949eb0, 0x1, 0x1)
 /tmp/tmp.WLQdFV1s5S/src/gopkg.in/check.v1/helpers.go:173 +0x64
github.com/ubuntu-core/snappy/integration-tests/testutils/cli.ExecCommand(0x1099a140, 0x109bf280, 0x4, 0x4, 0x0, 0x0)
 /tmp/tmp.WLQdFV1s5S/src/github.com/ubuntu-core/snappy/integration-tests/testutils/cli/cli.go:42 +0x1e4
github.com/ubuntu-core/snappy/integration-tests/tests.init.1()
 /tmp/tmp.WLQdFV1s5S/src/github.com/ubuntu-core/snappy/integration-tests/tests/base_test.go:52 +0x130
github.com/ubuntu-core/snappy/integration-tests/tests.init()
 /tmp/tmp.WLQdFV1s5S/src/github.com/ubuntu-core/snappy/integration-tests/tests/writablePaths_test.go:107 +0xc98
main.init()
 github.com/ubuntu-core/snappy/integration-tests/tests/_test/_testmain.go:56 +0x58
adt-run [17:00:15]: test integrationtests: -----------------------]
adt-run [17:00:15]: test integrationtests: - - - - - - - - - - results - - - - - - - - - -
integrationtests FAIL non-zero exit status 2
adt-run [17:00:15]: @@@@@@@@@@@@@@@@@@@@ summary
integrationtests FAIL non-zero exit status 2

S390X:
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-xenial/xenial/s390x/s/snapd/20160412_165651@/log.gz

adt-run [16:55:41]: test integrationtests: [-----------------------
Installing godeps
Obtaining dependencies
update github.com/cheggaaa/pb failed; trying to fetch newer version
github.com/cheggaaa/pb now at e8c7cc515bfde3e267957a3b110080ceed51354e
update github.com/gorilla/mux failed; trying to fetch newer version
github.com/gorilla/mux now at ee1815431e497d3850809578c93ab6705f1a19f7
update github.com/jessevdk/go-flags failed; trying to fetch newer version
github.com/jessevdk/go-flags now at 6b9493b3cb60367edd942144879646604089e3f7
update golang.org/x/crypto failed; trying to fetch newer version
golang.org/x/crypto now at 60052bd85f2d91293457e8811b0cf26b773de469
update golang.org/x/net failed; trying to fetch newer version
golang.org/x/net now at 3b90a77d2885fb0429e8a21ab72fc73ca6f8b401
update gopkg.in/check.v1 failed; trying to fetch newer version
gopkg.in/check.v1 now at 64131543e7896d5bcc6bd5a76287eb75ea96c673
update github.com/testing-cabal/subunit-go failed; trying to fetch newer version
github.com/testing-cabal/subunit-go now at 00b258565a5cf3adaa24b68d31c9e6ec3d2cdbe7
update github.com/gosexy/gettext failed; trying to fetch newer version
github.com/gosexy/gettext now at 98b7b91596d20b96909e6b60d57411547dd9959c
update gopkg.in/tylerb/graceful.v1 failed; trying to fetch newer version
gopkg.in/tylerb/graceful.v1 now at 48afeb21e2fcbcff0f30bd5ad6b97747b0fae38e
update github.com/coreos/go-systemd failed; trying to fetch newer version
github.com/coreos/go-systemd now at f743bc15d6bddd23662280b4ad20f7c874cdd5ad
update github.com/kr/pty failed; trying to fetch newer version
github.com/kr/pty now at 05017fcccf23c823bfdea560dcc958a136e54fb7
update github.com/mvo5/uboot-go failed; trying to fetch newer version
github.com/mvo5/uboot-go now at 361f6ebcbb54f389d15dc9faefa000e996ba3e37
update github.com/peterh/liner failed; trying to fetch newer version
github.com/peterh/liner now at 1bb0d1c1a25ed393d8feb09bab039b2b1b1fbced
update gopkg.in/yaml.v2 failed; trying to fetch newer version
gopkg.in/yaml.v2 now at 49c95bdc21843256fb6c4e0d370a05f24a0bf213
update github.com/mvo5/goconfigparser failed; trying to fetch newer version
github.com/mvo5/goconfigparser now at 26426272dda20cc76aa1fa44286dc743d2972fe8
update github.com/gorilla/context failed; trying to fetch newer version
github.com/gorilla/context now at 1c83b3eabd45b6d76072b66b746c20815fb2872d
update github.com/gorilla/websocket failed; trying to fetch newer version
github.com/gorilla/websocket now at 234959944d9cf05229b02e8b386e5cffe1e4e04a
update gopkg.in/tomb.v2 failed; trying to fetch newer version
gopkg.in/tomb.v2 now at 14b3d72120e8d10ea6e6b7f87f7175734b1faab8
sudo systemctl stop snappy-autopilot.timer
sudo: no tty present and no askpass program specified
panic: runtime error: invalid memory address or nil pointer dereference
[signal 0xb code=0x1 addr=0x0 pc=0x2aa31622534]

goroutine 1 [running]:
panic(0x2aa31ad5e40, 0xc8200100b0)
 /usr/lib/go-1.6/src/runtime/panic.go:464 +0x400
gopkg.in/check%2ev1.(*methodType).PC(0x0, 0x2aa3163cf7a)
 /tmp/tmp.iotp1ZiRLc/src/gopkg.in/check.v1/check.go:59 +0x24
gopkg.in/check%2ev1.(*C).logCaller(0xc820104000, 0x3)
 /tmp/tmp.iotp1ZiRLc/src/gopkg.in/check.v1/check.go:275 +0xb2
gopkg.in/check%2ev1.(*C).internalCheck(0xc820104000, 0x2aa31b8ce68, 0x6, 0x2aa31b62de0, 0xc8200f2ac0, 0x3ffbc534568, 0xc820030028, 0xc820051da0, 0x0, 0x1, ...)
 /tmp/tmp.iotp1ZiRLc/src/gopkg.in/check.v1/helpers.go:216 +0xd48
gopkg.in/check%2ev1.(*C).Assert(0xc820104000, 0x2aa31b62de0, 0xc8200f2ac0, 0x3ffbc534568, 0xc820030028, 0xc820051da0, 0x1, 0x1)
 /tmp/tmp.iotp1ZiRLc/src/gopkg.in/check.v1/helpers.go:173 +0x90
github.com/ubuntu-core/snappy/integration-tests/testutils/cli.ExecCommand(0xc820104000, 0xc82000bcc0, 0x4, 0x4, 0x0, 0x0)
 /tmp/tmp.iotp1ZiRLc/src/github.com/ubuntu-core/snappy/integration-tests/testutils/cli/cli.go:42 +0x26a
github.com/ubuntu-core/snappy/integration-tests/tests.init.1()
 /tmp/tmp.iotp1ZiRLc/src/github.com/ubuntu-core/snappy/integration-tests/tests/base_test.go:52 +0x160
github.com/ubuntu-core/snappy/integration-tests/tests.init()
 /tmp/tmp.iotp1ZiRLc/src/github.com/ubuntu-core/snappy/integration-tests/tests/writablePaths_test.go:107 +0xfb0
main.init()
 github.com/ubuntu-core/snappy/integration-tests/tests/_test/_testmain.go:56 +0x76
adt-run [16:56:49]: test integrationtests: -----------------------]
adt-run [16:56:49]: test integrationtests: - - - - - - - - - - results - - - - - - - - - -
integrationtests FAIL non-zero exit status 2
adt-run [16:56:49]: @@@@@@@@@@@@@@@@@@@@ summary
integrationtests FAIL non-zero exit status 2

Daniel Holbach (dholbach) wrote :

Related to bug 1551570?

Michael Vogt (mvo) on 2016-04-13
summary: - integration tests fail on armhf and s390x
+ autopkg tests fail on armhf and s390x
description: updated
Michael Vogt (mvo) wrote :

The culprit seems to be: " sudo: no tty present and no askpass program specified"

Changed in snappy:
status: New → Confirmed
importance: Undecided → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers