error trying to execute snap binary

Bug #1545786 reported by Federico Gimenez
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Snappy
Critical
Unassigned
ubuntu-core-launcher (Ubuntu)
Critical
Jamie Strandboge

Bug Description

Steps to reproduce (versions included in command's output):

ubuntu@localhost:~$ sudo snappy install hello-world/edge
Installing hello-world/edge
Name Date Version Developer
canonical-pc 2016-02-02 3.0 canonical
canonical-pc-linux 2016-02-03 4.4.0-2-1 canonical
hello-world 2016-01-26 3.0 canonical
ubuntu-core 2016-02-12 16.04.0-14 canonical
ubuntu@localhost:~$ hello-world.echo
failed to create user data directory. errmsg: Permission denied

Thanks!

description: updated
Revision history for this message
Leo Arias (elopio) wrote :

Set priority as critical because it makes the automated tests fail.

Changed in snappy:
importance: Undecided → Critical
status: New → Triaged
Revision history for this message
Jamie Strandboge (jdstrand) wrote :

It looks like the apparmor profile for the launcher didn't get updated for the recent commits. I'll fix that up and upload to xenial and the image ppa.

Changed in ubuntu-core-launcher (Ubuntu):
status: New → Triaged
importance: Undecided → Critical
assignee: nobody → Jamie Strandboge (jdstrand)
Revision history for this message
Jamie Strandboge (jdstrand) wrote :

Uploaded to xenial and the image PPA so the fix should be in the next OS image. This is marked against Snappy but doesn't affect 15.04, so not sure how to triage the upstream task (putting as Fix Committed for now).

Changed in ubuntu-core-launcher (Ubuntu):
status: Triaged → In Progress
status: In Progress → Fix Committed
Changed in snappy:
status: Triaged → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-core-launcher - 1.0.17

---------------
ubuntu-core-launcher (1.0.17) xenial; urgency=medium

  * debian/usr.bin.ubuntu-core-launcher: add directory reads needed for
    creating directories for SNAP_USER_DATA. Also add accesses for shared
    memory directories for when they are supported. (LP: #1545786)

 -- Jamie Strandboge <email address hidden> Tue, 16 Feb 2016 11:34:35 -0600

Changed in ubuntu-core-launcher (Ubuntu):
status: Fix Committed → Fix Released
Leo Arias (elopio)
Changed in snappy:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers