wifi-ap snap does not work even after reinstall (not handing out ip addresses)

Bug #1873296 reported by Daniel Gunzinger on 2020-04-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
snappy-hwe-snaps
Undecided
Unassigned

Bug Description

After a restart wifi-ap stopped working (as in handing out IP addresses) seemingly without a reason.
Even after reinstalling the wifi-ap snap it could not start successfully, repeated attempts for this were made, using different dhcp.range-start and wifi.address values.

Two things I noticed in the logs/journal-output were that iptables complains about a bad rule and not finding an existing chain/target/match by a particular name shortly before dnsmasq complains about the wifi.address already being in use.

Due to the dnsmasq complaint I have tried reinstalling the snap repeatedly and trying different previously unused wifi.address values, however the same error pattern always persists.

In this current state the wifi access point is created and running, but every device that connects hangs and then disconnects again, as no IP addresses are handed out to connecting devices.

Thank you for reading, please let me know if there is extra information I can provide.

[wifi-ap.status:
ap.active: true]

[wifi-ap.config:
debug: false
dhcp.lease-time: 12h
dhcp.range-start: 10.0.60.2
dhcp.range-stop: 10.0.60.199
disabled: false
share.disabled: false
share.network-interface: enp7s0
wifi.address: 10.0.60.1
wifi.channel: 6
wifi.country-code: DE
wifi.hostapd-driver: nl80211
wifi.interface: wlp6s0
wifi.interface-mode: direct
wifi.netmask: 255.255.255.0
wifi.operation-mode: g
wifi.security: wpa2
wifi.security-passphrase: <REDACTED>
wifi.ssid: <REDACTED>]

This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers