Snapd might prevent the Huawei E392 working

Bug #1993737 reported by bushido
This bug affects 1 person
Affects Status Importance Assigned to Milestone

Bug Description

I have tried which solution kept me connecting until error and no internet.

When I tried "$ sudo usb_modeswitch -v 12d1 -p 151a -V 12d1 -P 151b -W -M “55534243123456780000000000000011062000000100000000000000000000″" from, I got "Take all parameters from the command line

    usb_modeswitch: handle USB devices with multiple modes
    Version 2.6.1 (C) Josua Dietze 2017
    Based on libusb1/libusbx


DefaultVendor= 0x12d1 DefaultProduct= 0x151a TargetVendor= 0x12d1 TargetProduct= 0x151b MessageContent="“55534243123456780000000000000011062000000100000000000000000000″"

MessageContent “55534243123456780000000000000011062000000100000000000000000000″ is not a hex string. Abort"

I have downloaded "usb-modeswitch-data-20191128.tar.bz2", "usb-modeswitch-2.6.0.tar.bz2" and "libusb-1.0.26" but I do not know how to execute any "make" or use these archives via a simple gui.

I use Huawei E392 with Ubuntu 22.04.1 LTS 64-bit (gnome 42.4). I have installed the additional driver suggested by Ubuntu:

" journalctl -f" result is at there:
"snap list" result is at there:

I am approaching you via Launcpad as the user "nobody" at gave me a hint for it.

I have tried many codes from without any luck. Please suggest any new ideas!

bushido (olav-magi)
description: updated
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.