snap-exec not built statically in openSUSE packages

Bug #1900807 reported by Maciej Borzecki
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
snapd
High
Maciej Borzecki

Bug Description

On Tumbleweed, the snapd-2.47.1-2.1.x86_64 package from system:snappy is built incorrectly. The binaries: snap-exec, snapctl are not built statically. Thus when starting some snaps one can see:

/usr/lib/snapd/snap-exec: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.32' not found (required by /usr/lib/snapd/snap-exec)

Changed in snapd:
status: New → In Progress
importance: Undecided → High
assignee: nobody → Maciej Borzecki (maciek-borzecki)
Revision history for this message
Maciej Borzecki (maciek-borzecki) wrote :
Revision history for this message
Maciej Borzecki (maciek-borzecki) wrote :

Submit request landed https://build.opensuse.org/request/show/843213 the packages have been rebuilt now.

Changed in snapd:
status: In Progress → Fix Committed
Revision history for this message
Timo Jyrinki (timo-jyrinki) wrote :

zypper gave me now the updated build system:snappy and snap packages are working fine again, thank you!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers