uc20 config with wifi never activates interface during install

Bug #1881674 reported by Paul Larson on 2020-06-01
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
snapd
High
Unassigned
subiquity
Undecided
Unassigned

Bug Description

The device I'm testing on right now is a pi3b+ with the armhf image from 20200529.3, but I don't think it's likely to just be affecting this image.

== Steps to reproduce ==
1. Make sure you are on a device with wifi, ethernet should be disconnected
2. During console-conf, select and configure the wifi interface
3. When proceeding to the next step, it says DHCPv4 is in unknown state, attempting to configure the account on the next screen fails because the network is not active.

Here's the wlan portion from the network connections screen in console conf, after I configured the interface and saved it. Notice how my only option is "Continue without network"

================================================================================
  Network connections
================================================================================
  Configure at least one interface this server can use to talk to other
  machines, and which preferably provides sufficient access for updates.

    NAME TYPE NOTES
  [ enxb827eb3e5571 eth not connected > ]
    disabled autoconfiguration failed
    b8:27:eb:3e:55:71 / Microchip Technology, Inc. (formerly SMSC) / 7800

  [ wlan0 wlan - > ]
    DHCPv4 unknown state None
    b8:27:eb:6b:00:24 / Unknown Vendor / Unknown Model

  [ Create bond > ]

                          [ Continue without network ]
                          [ Back ]

Paul Larson (pwlars) wrote :

Ok, I finally found how to get past this. Selecting ipv4 configuration on the interface and changing it to dhcp forces it online. However I really thought that when we used to configure this on uc18, it automatically did that. At the very least, it's not really obvious how to activate it right now

Changed in snapd:
status: New → Triaged
importance: Undecided → High
Ian Johnson (anonymouse67) wrote :

This did used to work in UC18 on the pi, so it definitely is a regression in console-conf / core20 snap.

tags: added: core20
Ian Johnson (anonymouse67) wrote :

Also I should say I have reproduced this every time on my UC20 rpi4 install, but I have not explicitly tried the beta image itself, but I'm sure that I have tried the core20 snap that is in the beta image with either a different image or a locally built image.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers