Add support for url scheme zoom

Bug #1880606 reported by Chris Burns on 2020-05-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
snapd
Medium
Zygmunt Krynicki

Bug Description

RE https://bugs.launchpad.net/snapd/+bug/1776873/comments/41
There should be support for zoomus:// and zoommtg:// links.
I am not an export on what that "means", I was just told that I should post here and say what schemes I'd like whitelisted. (See the linked comment for details)

Ian Johnson (anonymouse67) wrote :

Hi, which snap specifically does not work with these zoom links? Can you also post the output of `snap version` ?

Lastly, we have added better support for snapd to forward requests to xdg-open from inside a strict snap to xdg-desktop-portal on the host if that is available, which should solve this sort of issue generically, can you try refreshing to snapd snap candidate channel (which is version 2.45) and try again? Specifically run:

```
snap install snapd --beta || snap refresh snapd --beta
```

Changed in snapd:
status: New → Incomplete
Chris Burns (makusu2) wrote :

Hey there!
It's specifically Chromium.
```
➜ ~ snap version
snap 2.44.3+20.04
snapd 2.44.3+20.04
series 16
ubuntu 20.04
kernel 5.4.0-31-generic
```

I had to run `snap refresh snapd --beta`, but after doing that:
```
➜ ~ snap refresh snapd --beta
2020-05-26T09:57:07-04:00 INFO Waiting for restart...
snapd (beta) 2.45+git12.g48ab8c0 from Canonical✓ refreshed
```

It's still the same as before (opening a Zoom link in Chromium still doesn't open Zoom). Do I need to reinstall Chromium, or do something else?

I'm not sure what you're asking me to do with xdg-desktop-portal, so I might be misunderstanding some parts. How can I check if it's "available"?

Samuele Pedroni (pedronis) wrote :

zoommtg should be supported in 2.45, we didn't get mentions or patches for zoomus ? what's the difference

Chris Burns (makusu2) wrote :

I'm not sure what causes the difference, but sometimes the link will be zoomus. I assume it has something to do with how the host shares the link, but I don't know what exactly.

Zygmunt Krynicki (zyga) wrote :

I just looked at the code and we indeed only support "zoommtg" and not "zoomus". This is documented on the zoom API page: https://marketplace.zoom.us/docs/guides/guides/client-url-schemes

Changed in snapd:
importance: Undecided → Medium
status: Incomplete → Confirmed
Zygmunt Krynicki (zyga) wrote :

We should support "zoomus" and "zoomphonecall" for complete experience.

Zygmunt Krynicki (zyga) wrote :

I've sent a pull request with those two schemes: https://github.com/snapcore/snapd/pull/8910

Changed in snapd:
assignee: nobody → Zygmunt Krynicki (zyga)
status: Confirmed → In Progress
Zygmunt Krynicki (zyga) on 2020-06-29
Changed in snapd:
milestone: none → 2.46
status: In Progress → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers