lxd-support interface doesn't appear to get properly connected/ready

Bug #1870201 reported by Chris Patterson on 2020-04-01
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
snapd
High
Unassigned

Bug Description

This sequence happens many times on our spread tests and on one install of LXD, `waitready` fails because it appears that lxd-interface wasn't properly connected/ready. It is the first time I've encountered such an error, but thought it worth reporting.

+ apt-get install -y snapd

Reading package lists...

Building dependency tree...

Reading state information...

snapd is already the newest version (2.42.1+18.04).

snapd set to manually installed.

The following packages were automatically installed and are no longer required:

  dns-root-data dnsmasq-base ebtables grub-pc-bin liblxc-common liblxc1

  libnuma1 libuv1 lxcfs lxd-client uidmap xdelta3

Use 'apt autoremove' to remove them.

0 upgraded, 0 newly installed, 0 to remove and 79 not upgraded.

+ '[' ubuntu-18.04-64 = ubuntu-16.04-64 ']'

+ '[' ubuntu-18.04-64 = ubuntu-18.04-64 ']'

+ apt-get remove --purge --yes lxd lxd-client

Reading package lists...

Building dependency tree...

Reading state information...

Package 'lxd' is not installed, so not removed

The following packages were automatically installed and are no longer required:

  dns-root-data dnsmasq-base ebtables grub-pc-bin liblxc-common liblxc1

  libnuma1 libuv1 lxcfs uidmap xdelta3

Use 'apt autoremove' to remove them.

The following packages will be REMOVED:

  lxd-client*

0 upgraded, 0 newly installed, 1 to remove and 79 not upgraded.

After this operation, 11.0 MB disk space will be freed.

(Reading database ... 145633 files and directories currently installed.)

Removing lxd-client (3.0.3-0ubuntu1~18.04.1) ...

Processing triggers for man-db (2.8.3-2ubuntu0.1) ...

+ snap install lxd

2020-03-26T13:23:59Z INFO Waiting for restart...

2020-03-26T13:24:00Z INFO Waiting for restart...

lxd 3.23 from Canonical* installed

+ lxd waitready --timeout=30

cat: /proc/self/attr/current: Permission denied

/snap/lxd/13987/commands/lxd: 6: exec: aa-exec: Permission denied

Chris Patterson (cjp256) wrote :

I suspect a new core is being pulled, wonder if that increases the chances of this problem appearing?

Changed in snappy:
status: New → Triaged
importance: Undecided → High
affects: snappy → snapd
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments