cannot use snapcraft to build snapd on focal

Bug #1862642 reported by Dimitri John Ledkov on 2020-02-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Snap Store
Undecided
Unassigned
Snapcraft
Undecided
Unassigned
snapd
High
Ian Johnson
snapcraft (Ubuntu)
Undecided
Unassigned
snapd (Ubuntu)
High
Unassigned

Bug Description

cannot use snapcraft to build snapd on focal

$ snap install snapcraft
$ git clone https://github.com/snapcore/snapd
$ cd snapd
$ snapcraft
....
fails

Depends on https://bugs.launchpad.net/snapcraft/+bug/1857019 being fixed, then snapd getting fixed, then drink champagne

tags: added: rls-ff-incoming
description: updated
Ian Johnson (anonymouse67) wrote :

Note that the reason this doesn't work is partially due to https://bugs.launchpad.net/snapcraft/+bug/1857019, which prevents the snapd snap snapcraft.yaml from being updated to "modern snapcraft". If that bug was fixed we could update the snapd snapcraft.yaml to modern and it would "just work".

Changed in snapd:
status: New → In Progress
assignee: nobody → Ian Johnson (anonymouse67)
Claudio Matsuoka (cmatsuoka) wrote :

Assigned to Ian as a reminder to unblock PR #7904 once the prerequisites are cleared.

Sergio Schvezov (sergiusens) wrote :

Added snapstore as the root cause for the workarounds needed in Snapcraft are because the Snap Store does not accept "type: snapd".

Ian Johnson (anonymouse67) wrote :

The store bug here is specifically about the snapd snap currently having `type: app` and not properly supporting transitioning the type to `type: snapd`.

Samuele will discuss this with the store team about how to move forward on that front.

Changed in snapcraft:
status: New → Fix Committed
Changed in snapcraft:
status: Fix Committed → Fix Released
Ian Johnson (anonymouse67) wrote :

This is fixed on snapd master and will be "released" with snapd 2.44.

Changed in snapd:
milestone: none → 2.44
importance: Undecided → High
status: In Progress → Fix Committed
Changed in snapd (Ubuntu):
status: New → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers