Cannot refresh from ubuntu-core 2.15.2 on raspberry pi "ubuntu core 16" image - snap-declaration for "snapweb": parsing assertion headers: expected 4 chars nesting prefix after multiline introduction "plugs:": " network:"

Bug #1802773 reported by Zygmunt Krynicki on 2018-11-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Snap Store
High
William Grant
snapd
High
Unassigned

Bug Description

I was reinstalling my fleet of devices when I noticed stable images cannot update due to a store response for snapweb.

zyga@localhost:~$ snap --version
snap 2.15.2
snapd 2.15.2
series 16

zyga@localhost:~$ sudo snap refresh
error: cannot refresh []: cannot refresh snap-declaration for "snapweb": parsing assertion headers: expected 4 chars nesting prefix after multiline introduction "plugs:": " network:"

zyga@localhost:~$ sudo snap refresh ubuntu-core
error: cannot refresh "ubuntu-core": cannot refresh snap-declaration for "snapweb": parsing assertion headers: expected 4 chars nesting prefix after multiline introduction "plugs:": " network:"

zyga@localhost:~$ sudo snap remove snapweb
snapweb removed

zyga@localhost:~$ sudo snap refresh ubuntu-core
[/] Make snap "ubuntu-core" (1799) available to the system
Broadcast message from <email address hidden> (Sun 2018-11-11 18:50:50 UTC):

reboot scheduled to update the system - temporarily cancel with 'sudo shutdown -c'
The system is going down for reboot at Sun 2018-11-11 19:00:50 UTC!

63.40 MB / 63.57 MB [===================================>_] 99.73 % 946.61 KB/s

ubuntu-core (beta) 16-2 from 'canonical' upgraded

Samuele Pedroni (pedronis) wrote :

this is likely related to a configuration change in the store that stopped interpreting missing max-format query param as max-format=0 on assertions.ubuntu.com/v1/assertions/<type>/<primary-key> requests

Changed in snapstore:
importance: Undecided → High
Samuele Pedroni (pedronis) wrote :

To be clear we do want to keep the new behavior on the snapdevicegw own endpoints, the assertions.ubutnu.com behavior is stricly for backward compatibility but it's fairly confusing curl using

Bret Barker (noise) on 2018-11-30
Changed in snapstore:
assignee: nobody → William Grant (wgrant)
Bret Barker (noise) wrote :

pedronis, can you complete your comment above? appears to have been cutoff.

William Grant (wgrant) on 2019-03-08
tags: added: regression snapstore-deployment
Zygmunt Krynicki (zyga) wrote :

I'm marking the store side of the bug as confirmed since this prevents anyone from using the images from http://cdimage.ubuntu.com/ubuntu-snappy/16.04/current/

zyga@core16:~$ sudo snap refresh
error: cannot refresh []: cannot refresh snap-declaration for "snapweb": parsing assertion headers: expected 4 chars nesting prefix after multiline introduction "plugs:": " network:"

Changed in snapstore:
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers