Add qt/qml support

Bug #1614797 reported by Robert Ancell on 2016-08-19
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
snapd-glib
Fix Released
Medium
Robert Ancell

Bug Description

Make a library that wraps snapd-glib with Qt objects. Make a QML module so this can be directly accessed from a QML application.

Related branches

Changed in snapd-glib:
status: Triaged → In Progress
assignee: nobody → Robert Ancell (robert-ancell)

I would like to know in wich state is this functionality, I´m developing a software-center for snapd in Qt/Qml and I would like to use it.

Also I have experience making this kind of wrapers: glib to Qt/Qml. So if you need help please let me know.

Robert Ancell (robert-ancell) wrote :

Hi Alexis! The code is actually complete, and in the branch which I just linked to this report (I forgot to link it). I've been trying to find someone to review it, if you could do that then that would be very helpful. Thanks!

Hi Robert!
I'm working on it. I'm not familiar with the lauchpad workflow. If I found bugs should I post them here as comments?

Robert Ancell (robert-ancell) wrote :

If you find issues in the merge proposal [1] add them as comments there, or you can propose a branch to merge into that one.

[1] https://code.launchpad.net/~robert-ancell/snapd-glib/qt/+merge/310247

Changed in snapd-glib:
status: In Progress → Fix Committed
milestone: none → 1.5
Changed in snapd-glib:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers