snapcraft build <part> ignores the part

Bug #1897337 reported by Kyle Fazzari
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Snapcraft
Medium
Sergio Schvezov

Bug Description

Using snapcraft v4.3:

$ snapcraft build part1
<snip>
Pulling part1
Pulling part2
Building part1
Building part2

I expect that to ONLY build "part1". Particularly given the help text:

$ snapcraft build --help
Usage: snapcraft build [OPTIONS] <part>...

  Build artifacts defined for a part.

  Examples:
      snapcraft build
      snapcraft build my-part1 my-part2
<snip>

Kyle Fazzari (kyrofa)
description: updated
Revision history for this message
Sergio Schvezov (sergiusens) wrote :

This seems to have never worked, while the CLI accepts these commands, the build provider's execute step only has step in its signature

Changed in snapcraft:
status: New → Triaged
importance: Undecided → Medium
assignee: nobody → Sergio Schvezov (sergiusens)
Revision history for this message
Kyle Fazzari (kyrofa) wrote :

It certainly worked in v2, not sure when it broke in v3 (I only recently upgraded to v3 for my larger projects, so it makes sense that I'm discovering these things now).

Revision history for this message
Chris Patterson (cjp256) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers