stage-packages don't ensure they come from trusted repo

Bug #1811304 reported by Kyle Fazzari on 2019-01-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Snapcraft
Status tracked in Trunk
Legacy
Medium
jeremie
Trunk
Wishlist
Kyle Fazzari

Bug Description

In xenial (core16, on which snapcraft is still based) apt allows insecure repositories by default. This changed in Zesty, which means snapcraft will break if it ever moves to core18. A simple plugin API change should occur in order to allow trusting repo keys, and then snapcraft should start ensure repos are trusted.

Kyle Fazzari (kyrofa) wrote :
Changed in snapcraft:
status: New → In Progress
importance: Undecided → Wishlist
assignee: nobody → Kyle Fazzari (kyrofa)
Changed in snapcraft:
milestone: none → 3.1
status: In Progress → Fix Committed
Changed in snapcraft:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers