snapcraft 2.43 snap can't access to HTTPS APT sources

Bug #1790819 reported by 林博仁(Buo-ren, Lin)
34
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Snapcraft
Status tracked in Trunk
Legacy
Fix Committed
Medium
Sergio Schvezov
Trunk
Fix Released
Medium
Sergio Schvezov

Bug Description

Found a bunch of the following error:

```
Failed to update the package cache: Some files could not be downloaded:

E:The method driver /snap/snapcraft/1803/usr/lib/apt/methods/https could not be found.
W:Is the package apt-transport-https installed?
```

Revision history for this message
Olivier Tilloy (osomon) wrote :

The same error has been reported to me by someone else who uses custom repositories on their build machine.

I cannot get my hands on a 2.42 snapcraft snap to check whether it contained the https method and it was removed in 2.43.

Changed in snapcraft:
status: New → Confirmed
Revision history for this message
Sergio Schvezov (sergiusens) wrote :

https is indeed missing.
Fix comming.

Changed in snapcraft:
status: Confirmed → Triaged
Revision history for this message
Sergio Schvezov (sergiusens) wrote :
Changed in snapcraft:
status: Triaged → In Progress
importance: Undecided → Medium
assignee: nobody → Sergio Schvezov (sergiusens)
Revision history for this message
Sergio Schvezov (sergiusens) wrote :

I suspect projects encountering this issue are not using a clean environment or adding remote sources (as in not part of Ubuntu) to the environment where things are building, is this a correct assessment?

Revision history for this message
Olivier Tilloy (osomon) wrote :

I think so, although I haven't observed the issue firsthand.

Revision history for this message
林博仁(Buo-ren, Lin) (buo-ren-lin) wrote :

@sergiusens

> is this a correct assessment?

Yes, as `snapcraft` happily runs on these environments I happened to make it run on my working system for smaller sized snaps like Snapcraft Template Plus and Tidy. This bug doesn't occur in other snaps I choose to run in LXD/Docker.

Revision history for this message
林博仁(Buo-ren, Lin) (buo-ren-lin) wrote :

An example APT source that can trigger this issue is the Git Large File System's official repo, but any HTTPS APT source should do.

Revision history for this message
Sergio Schvezov (sergiusens) wrote :

Thanks buo-ren-lin, I do have a fix and know how to trigger the regression, I am just looking for a very stable repo to use in a test to not re-introduce this regression. I would like to avoid create a fake https server for this as that would involved cert management among others.

Changed in snapcraft:
milestone: none → 2.44
Kyle Fazzari (kyrofa)
Changed in snapcraft:
status: In Progress → Fix Committed
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers