Building snap using base-18 is broken with 2.39

Bug #1752538 reported by Björn Tillenius
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Fix Released
Sergio Schvezov

Bug Description

We use base-18 when building/installing the MAAS snap, since we'll target bionic for the next MAAS release.

Things worked fine, until snapcraft 2.39 was released. Now building the MAAS snap fails:

I tried a simple patch to snapcraft:

This made the build succeed, but the resulting snap was broken. The python scripts couldn't find the non-system modules. Seems like the environment isn't set up, since the '/usr/bin/env python3' shebang got expanded to /usr/bin/python3. Further more, after manually putting the right shebang, the scripts failed like this:

The file is in the snap, but after some debugging I noticed that LD_LIBRARY_PATH isn't being set.

This problem seem to be related to building against base-18 on bionic. I tried building MAAS 2.3 with snapcraft 2.39 on xenial (against the core base), and that still works.

You can reproduce this bug by running building a snap of, using the attached base-18 snap for the base.

Revision history for this message
Björn Tillenius (bjornt) wrote :
Alberto Donato (ack)
Changed in snapcraft:
status: New → Confirmed
Revision history for this message
Björn Tillenius (bjornt) wrote :

I managed to finally build the MAAS snap using this patch to snapcraft:

Changed in snapcraft:
status: Confirmed → Fix Committed
assignee: nobody → Sergio Schvezov (sergiusens)
importance: Undecided → Wishlist
Changed in snapcraft:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.