liblz4 is needed (?) but not installed

Bug #1748340 reported by Carlos Alexandro Becker
This bug report is a duplicate of:  Bug #1752964: Snapcraft snap broken on trusty. Edit Remove
This bug affects 1 person
Affects Status Importance Assigned to Milestone

Bug Description

So, goreleaser's builds suddenly started to fail.

Example of a failed build:

Snapping 'mybin' ...
              /snap/snapcraft/1094/usr/bin/mksquashfs: error while loading shared libraries: cannot open shared object file: No such file or directory

So, my first try was to install `liblz4-dev`, which fixes the issue.

I'm not very familiar with snapcraft. I tried to find the commit that broke it, but I didn't really know where to look.

Things I know:
- it was working until yesterday, but `--candidate` was broken for more time
- travis uses ubuntu trusty (which maybe is relevant?)

Anyway, I fixed it for my use case here:


Revision history for this message
Kyle Fazzari (kyrofa) wrote :

Thank you for logging this issue! Although you technically logged it first, there's a little more info in bug #1752964 so I'll mark this one as the dupe.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.