error message for expired macaroon is not helpful

Bug #1745264 reported by Leo Arias
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Snapcraft
Medium
Chris Patterson

Bug Description

Exactly a year after I enabled the ci integration from travis for the IPFS snap, it started to fail with:

Pushing ipfs_v0.4.13_amd64.snap
After pushing, an attempt to release to ['edge'] will be made
Using local configuration (`.snapcraft/snapcraft.cfg`), changes will not be persisted.
Preparing to push '/home/travis/build/elopio/ipfs-snap/ipfs_v0.4.13_amd64.snap' to the store.
Received 401: '{"error_list": [{"message": "Authorization Required", "code": "macaroon-permission-required"}]}'

Chris Patterson (cjp256)
Changed in snapcraft:
assignee: nobody → Chris Patterson (cjp256)
Revision history for this message
Chris Patterson (cjp256) wrote :

A error message could be improved: "Authentication failed: macaroon has expired or is invalid."

Changed in snapcraft:
status: New → Triaged
importance: Undecided → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers