truffle fails to build: ENOTFOUND registry.yarnpkg.com registry.yarnpkg.com:443

Bug #1733718 reported by Leo Arias on 2017-11-21
32
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Snapcraft
Undecided
Colin Watson
snapcraft (Ubuntu)
Undecided
Unassigned

Bug Description

I've configured a mirror of truffle [1] in launchpad to build the snap. It uses the nodejs snapcraft plugin and yarn as the package manager, and that's failing with:

error An unexpected error occurred: "https://registry.yarnpkg.com/solc: getaddrinfo ENOTFOUND registry.yarnpkg.com registry.yarnpkg.com:443".

The full build log is in [2]. The snap source is in [3].

[1] https://github.com/trufflesuite/truffle
[2] https://launchpadlibrarian.net/346630878/buildlog_snap_ubuntu_xenial_armhf_truffle_BUILDING.txt.gz
[3] https://github.com/JaquerEspeis/truffle/blob/afb30e38e68bdc25cd232adb19281db1b7c756c1/snap/snapcraft.yaml

Leo Arias (elopio) wrote :

This seems to be affecting heroku too:
https://build.snapcraft.io/user/heroku/cli/109249

Colin Watson (cjwatson) wrote :

yarn apparently doesn't pick up proxy configuration from the environment, and needs to be told explicitly. I've filed a snapcraft PR to fix this (https://github.com/snapcore/snapcraft/pull/1754).

affects: launchpad-buildd → snapcraft
Changed in snapcraft:
assignee: nobody → Colin Watson (cjwatson)
status: New → In Progress
Changed in snapcraft:
status: In Progress → Fix Committed
Changed in snapcraft:
status: Fix Committed → Fix Released
Adam Collard (adam-collard) wrote :

Confirming Ubuntu bug, based on dupe #1733718.

As and when snapcraft with this fix in get's SRU'd, the launchpad builders can start using it and this will be fixed for build.snapcraft.io users.

Changed in snapcraft (Ubuntu):
status: New → Confirmed
Adam Collard (adam-collard) wrote :

Err, I meant bug 1745579 as the dupe

Alvaro Uría (aluria) on 2018-01-30
tags: added: canonical-bootstack
Sergio Schvezov (sergiusens) wrote :

The fix for this is in xenial-proposed awaiting final SRU testing.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers