snapcraft update won't fetch from SNAPCRAFT_PARTS_URI

Bug #1719928 reported by Aleix Pol on 2017-09-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Snapcraft
High
Christian Dywan

Bug Description

I looked into it with Sergio, he pointed out that it's probably because ~/.local/share/snapcraft/headers.yaml says it's already up to date.

Removing the file allows `snapcraft update` to see the right parts.yaml file.

More information about the issue here:
https://bugs.kde.org/show_bug.cgi?id=385062

Changed in snapcraft:
status: New → Triaged
importance: Undecided → High
assignee: nobody → Christian Dywan (kalikiana)
Christian Dywan (kalikiana) wrote :

The problem is that the files are oblivious of SNAPCRAFT_PARTS_URI so it only really works if you set and use the same one, which is true for test cases.

I'm thinking we could use the hashed URI for a subfolder name so it becomes ~/.local/share/snapcraft/parts/abcdef0123456789/parts.yaml (and headers.yaml), using a "parts" subfolder while we're moving it in case we want to have other files in there in the future.

Christian Dywan (kalikiana) wrote :
Changed in snapcraft:
status: Triaged → In Progress
Changed in snapcraft:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers