Snap delta too large warning language can be improved

Bug #1681692 reported by Mark Shuttleworth on 2017-04-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Snapcraft
Medium
Gustavo Silva

Bug Description

Saw this today:

  Error generating delta: delta generated was too large.
  Falling back to pushing full snap...

Can we change this to a single line, please:

  Large delta, pushing full snap.

If we have a simple definition of large, then let's be explicit, for example:

  Delta saving is less than 20%, pushing full snap.

Leo Arias (elopio) on 2017-04-18
Changed in snapcraft:
status: New → Confirmed
importance: Undecided → Medium
tags: added: bitesize ui
Kyle Fazzari (kyrofa) wrote :
Changed in snapcraft:
status: Confirmed → Fix Committed
milestone: none → 2.32
assignee: nobody → Gustavo Silva (gsilvapt)
Kyle Fazzari (kyrofa) on 2017-06-27
Changed in snapcraft:
status: Fix Committed → Fix Released
Leo Arias (elopio) wrote :

Wait wait, with Gustavo we only made one change to send the percentage from the backend to the UI. The text is still not what Mark suggested. It currently says:

Error generating delta: delta saving is less than 10%.
Falling back to pushing full snap...

I'm bringing this back to confirmed, and adding the tag to get somebody from the design team to take a look at our delta error messages because we didn't review them during the sprint.

Changed in snapcraft:
status: Fix Released → Confirmed
tags: added: needs-design-review
Carla Berkers (carlaberkers) wrote :

Hi Leo, as far as I can tell your proposal looks sensible.

Do you use a convention for how to phrase error messages?

Kyle Fazzari (kyrofa) wrote :

Whoops, sorry guys, looks like I jumped the gun there. Let's please be clear in the PR if the buglink isn't completely fixed by it.

Changed in snapcraft:
milestone: 2.32 → none
Leo Arias (elopio) wrote :

@Carla, sorry for the late response.

We try to make errors consistent. One time I collected all the error messages and we looked at them, making a few changes to make them nicer. It might be time to do it again, to make sure that the new ones are being consistent too.

I'm marking this as triaged, so we can rephrase the message.

Changed in snapcraft:
status: Confirmed → Triaged
Gustavo Silva (gsilvapt) wrote :

@elopio how are things on this design request? Perhaps we could work on this one some time soon?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers