problems on revoking a gpg key for signing assertions

Bug #1669471 reported by Domotz Ubuntu Core on 2017-03-02
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Snap Store
Undecided
Facundo Batista
Snapcraft
High
Unassigned

Bug Description

I registered a key for my first assertion, then I received a mail from
Ubuntu store with the command able to remove a gpg key from backend:

    snapcraft revoke-key name_of_key

This command don't work and produces the following output:

snapcraft revoke-key name_of_key

Usage:
  snapcraft [options] [--enable-geoip --no-parallel-build]
  snapcraft [options] init
  snapcraft [options] pull [<part> ...] [--enable-geoip]
  snapcraft [options] build [<part> ...] [--no-parallel-build]
  snapcraft [options] stage [<part> ...]
  snapcraft [options] prime [<part> ...]
  snapcraft [options] strip [<part> ...]
  snapcraft [options] clean [<part> ...] [--step <step>]
  snapcraft [options] snap [<directory> --output <snap-file>]
  snapcraft [options] cleanbuild [--remote=<remote>]
  snapcraft [options] login
  snapcraft [options] logout
  snapcraft [options] list-registered
  snapcraft [options] registered
  snapcraft [options] list-keys
  snapcraft [options] keys
  snapcraft [options] create-key [<key-name>]
  snapcraft [options] register-key [<key-name>]
  snapcraft [options] register <snap-name> [--private]
  snapcraft [options] sign-build <snap-file> [--key-name=<key-name>]
[--local]
  snapcraft [options] upload <snap-file>
  snapcraft [options] push <snap-file> [--release <channels>]
  snapcraft [options] release <snap-name> <revision> <channel>
  snapcraft [options] status <snap-name> [--series=<series>] [--arch=<arch>]
  snapcraft [options] history <snap-name> [--series=<series>]
[--arch=<arch>]
  snapcraft [options] close <snap-name> <channel_names>...
  snapcraft [options] list-plugins
  snapcraft [options] plugins
  snapcraft [options] tour [<directory>]
  snapcraft [options] update
  snapcraft [options] gated <snap-name>
  snapcraft [options] validate <snap-name> <validation>...
[--key-name=<key-name>]
  snapcraft [options] define <part-name>
  snapcraft [options] search [<query> ...]
  snapcraft [options] enable-ci [<ci-system>] [--refresh]
  snapcraft [options] help (topics | <plugin> | <topic>) [--devel]
  snapcraft (-h | --help)
  snapcraft --version

snapcraft --version -> 2.27.1

Leo Arias (elopio) wrote :

I added snapcraft because the revoke-key command should be added. I think this should be high priority.
On the store side, the email should not mention revoke-key until it is implemented.

Changed in snapstore:
status: New → Confirmed
Changed in snapcraft:
status: New → Confirmed
importance: Undecided → High
tags: added: store
Changed in snapstore:
assignee: nobody → Facundo Batista (facundo)
Changed in snapstore:
status: Confirmed → In Progress
Changed in snapstore:
status: In Progress → Fix Committed
Changed in snapstore:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers