Implement snapcraft register

Bug #1595012 reported by Sergio Schvezov
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Snapcraft
Wishlist
Leo Arias
snapcraft (Ubuntu)
Wishlist
Unassigned
Xenial
Wishlist
Unassigned
Yakkety
Wishlist
Unassigned

Bug Description

This is part of the set of store commands to make development workflow better.

[Impact]

 * Users trying to upload a snap form the command line have to go to the website first.

 * This command will improve the usability of the upload.

[Test Case]

 * Run snapcraft register without login, get an error.
 * Run snapcraft register with an invalid name (already registered or reserved), get an error.
 * Run snapcraft register with an unregistered name. Get a success message. Check that the error is registered in the store. Upload a snap with that name.

[Regression Potential]

 * None. This is a new command.

Revision history for this message
Sergio Schvezov (sergiusens) wrote :
Leo Arias (elopio)
description: updated
Changed in snapcraft:
status: In Progress → Fix Committed
Revision history for this message
Steve Langasek (vorlon) wrote : Please test proposed package

Hello Sergio, or anyone else affected,

Accepted snapcraft into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/snapcraft/2.12 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Revision history for this message
Leo Arias (elopio) wrote :

Tested in an up-to-date xenial:

- enabled -proposed
- update snapcraft-parser to 2.12
- snapcraft register <- it fails with a nice error, login required.
- snapcraft login
- snapcraft register hello <- it fails.
- snapcraft register u1test20160627 <- it works.
- snapcraft register u1test20160627 <- it fails.
- snapcraft register invalid//a <- it fails.

In this release, we just implemented the basic registration flow. I've reported some bugs to improve the error messages displayed to the user to explain how to solve the problem.

I'm going to mark this as verified, thanks Steve!

tags: added: verification-done
removed: verification-needed
Changed in snapcraft:
status: Fix Committed → Fix Released
Revision history for this message
Chris J Arges (arges) wrote : Update Released

The verification of the Stable Release Update for snapcraft has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in snapcraft (Ubuntu Xenial):
status: New → Confirmed
Changed in snapcraft (Ubuntu Yakkety):
status: New → Confirmed
Mathew Hodson (mhodson)
affects: Ubuntu Xenial → snapcraft (Ubuntu Xenial)
Changed in snapcraft (Ubuntu Xenial):
importance: Undecided → Wishlist
status: New → Fix Released
Changed in snapcraft (Ubuntu Yakkety):
status: Confirmed → Fix Released
importance: Undecided → Wishlist
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers