Parts repository is undocumented

Bug #1582499 reported by Gustavo Niemeyer on 2016-05-17
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Snapcraft
Low
Joe Talbott

Bug Description

We discussed in the sprint that there aren't too many contributions for parts, and I have a hint about why: it's not documented.

This is the documentation for parts:

https://developer.ubuntu.com/en/snappy/build-apps/snapcraft-parts/

It doesn't even mention the idea of parts being imported, which means it also doesn't mention the location for such details.

Then, in the advanced section, it is very tersely mentioned:

"""
As we never define the curl part in the above example, snapcraft will check the Ubuntu Wiki, which is where we currently host examples of successful snapcraft parts.
"""

Again, no proper coverage, and no links to where these are actually defined.

The only place I could find a link to the wiki location is inside the snapcraft.yaml syntax definition:

"""
plugin: Specifies the plugin name that will manage this part. Snapcraft will pass to it all the other user-specified part options. If plugin is not defined, the wiki will be searched for the part
"""

Again, super terse and hidden in a non-obvious place. I could only find it because I knew what I was looking for.

Most people will never even know about this feature.

[Impact]

 * The parts wiki is not well documented.

[Test Case]

 * Read the new snapcraft parts docs.

[Regression Potential]

 * N/A. This is only a documentation change.

Changed in snapcraft:
status: New → Triaged
Changed in snapcraft:
milestone: none → 2.12
importance: Undecided → Low
assignee: nobody → Joe Talbott (joetalbott)
status: Triaged → Fix Committed

Hello Gustavo, or anyone else affected,

Accepted snapcraft into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/snapcraft/2.12 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Leo Arias (elopio) wrote :

There is nothing to verify in xenial-proposed here. I'm marking it as done.

Thanks Steve!

tags: added: verification-done
removed: verification-needed
Changed in snapcraft:
status: Fix Committed → Fix Released
no longer affects: Ubuntu Yakkety
no longer affects: Ubuntu Xenial

The verification of the Stable Release Update for snapcraft has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers