Not creating ephemeral containers

Bug #1577548 reported by Evan on 2016-05-02
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Snapcraft
High
Evan
snapcraft (Ubuntu)
High
Unassigned
Xenial
High
Unassigned
Yakkety
High
Unassigned

Bug Description

snapcraft cleanbuild is creating persistent containers and is not cleaning them up. Sergio says it should be creating ephemeral containers instead.

[Impact]

 * Users of cleanbuild get a lot of leftover containers.

[Test Case]

 * snapcraft init
 * snapcraft cleanbuild
 * lxc list
 * check that no snapcraft containers are listed.

[Regression Potential]

 * This could break cleanbuild. The integration test for cleanbuild is currently disabaled, so this will have to be tested manually. Bug #1593529 created to test this automatically.

Evan (ev) wrote :
Download full text (46.7 KiB)

Logs:

ev@elsa:~/branches/whoopsie/snappy$ snapcraft cleanbuild
Creating snapcraft-persuadingly-dolomitic-randal
Starting snapcraft-persuadingly-dolomitic-randal
Setting up container with project assets
./
./src/
./src/whoopsie.h
./src/logging.h
./src/recoverable-problem.h
./src/tests/
./src/tests/Makefile
./src/tests/test_identifier.c
./src/tests/recoverable_mock.sh
./src/tests/data/
./src/tests/data/_usr_bin_gedit.1000.crash
./src/tests/data/etc/
./src/tests/data/etc/passwd
./src/tests/data/crash/
./src/tests/data/crash/valid_empty_value
./src/tests/data/crash/invalid_key_no_value2
./src/tests/data/crash/invalid-file-is-dir/
./src/tests/data/crash/invalid_value_embedded_nul
./src/tests/data/crash/invalid_key_embedded_nul
./src/tests/data/crash/invalid_trailing2
./src/tests/data/crash/invalid_value
./src/tests/data/crash/invalid_key_special_chars
./src/tests/data/crash/valid
./src/tests/data/crash/invalid_key_leading_spaces2
./src/tests/data/crash/invalid_key_no_value
./src/tests/data/crash/invalid_symlink
./src/tests/data/crash/unicode
./src/tests/data/crash/invalid_no_spaces
./src/tests/data/crash/invalid_key_leading_spaces
./src/tests/data/crash/invalid_value2
./src/tests/test_logging.c
./src/tests/test_recoverable.c
./src/tests/test_parse_report.c
./src/tests/test_utils.c
./src/tests/test_monitor.c
./src/monitor.c
./src/identifier.c
./src/utils.h
./src/connectivity.h
./src/connectivity.c
./src/logging.c
./src/utils.c
./src/monitor.h
./src/whoopsie.c
./src/identifier.h
./src/globals.h
./src/recoverable-problem.c
./Makefile
./.bzr/
./.bzr/branch/
./.bzr/branch/last-revision
./.bzr/branch/branch.conf
./.bzr/branch/format
./.bzr/branch/tags
./.bzr/branch/lock/
./.bzr/repository/
./.bzr/repository/upload/
./.bzr/repository/packs/
./.bzr/repository/packs/b3c48ec1ef30e01b66680a5bf20f0046.pack
./.bzr/repository/packs/146438d3f49632b06d12ee96568a0783.pack
./.bzr/repository/pack-names
./.bzr/repository/obsolete_packs/
./.bzr/repository/format
./.bzr/repository/lock/
./.bzr/repository/indices/
./.bzr/repository/indices/b3c48ec1ef30e01b66680a5bf20f0046.cix
./.bzr/repository/indices/b3c48ec1ef30e01b66680a5bf20f0046.iix
./.bzr/repository/indices/146438d3f49632b06d12ee96568a0783.cix
./.bzr/repository/indices/b3c48ec1ef30e01b66680a5bf20f0046.rix
./.bzr/repository/indices/b3c48ec1ef30e01b66680a5bf20f0046.tix
./.bzr/repository/indices/146438d3f49632b06d12ee96568a0783.iix
./.bzr/repository/indices/b3c48ec1ef30e01b66680a5bf20f0046.six
./.bzr/repository/indices/146438d3f49632b06d12ee96568a0783.six
./.bzr/repository/indices/146438d3f49632b06d12ee96568a0783.tix
./.bzr/repository/indices/146438d3f49632b06d12ee96568a0783.rix
./.bzr/README
./.bzr/branch-lock/
./.bzr/branch-format
./.bzr/checkout/
./.bzr/checkout/views
./.bzr/checkout/conflicts
./.bzr/checkout/dirstate
./.bzr/checkout/format
./.bzr/checkout/shelf/
./.bzr/checkout/merge-hashes
./.bzr/checkout/lock/
./data/
./data/whoopsie.service
./data/whoopsie.conf
./data/brofono.conf
./data/whoopsie.py
./snapcraft.yaml
./tools/
./tools/check_valgrind
./tools/brofono.py
./tools/suppressions.supp
./setup/
./setup/whoopsie.desktop
./lib/
./lib/libwhoopsie.pc
./lib/bson/
./lib/bson/encoding.c
./lib/bson/bson.c
./lib...

description: updated
Leo Arias (elopio) wrote :
Changed in snapcraft:
status: New → In Progress
importance: Undecided → High
assignee: nobody → Evan Dandrea (ev)
milestone: none → 2.12
Leo Arias (elopio) on 2016-06-17
description: updated
Evan (ev) on 2016-06-17
Changed in snapcraft:
status: In Progress → Fix Committed

Hello Evan, or anyone else affected,

Accepted snapcraft into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/snapcraft/2.12 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Leo Arias (elopio) wrote :

Tested in an up-to-date xenial:

- enabled -proposed
- update snapcraft to 2.12
- install and configure lxd
- snapcraft cleanbuild
- lxc list
- verified it doesn't show containers.

I'm going to mark this as verified, thanks Steve!

tags: added: verification-done
removed: verification-needed
Changed in snapcraft:
status: Fix Committed → Fix Released

The verification of the Stable Release Update for snapcraft has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

affects: Ubuntu Xenial → snapcraft (Ubuntu Xenial)
Changed in snapcraft (Ubuntu Xenial):
importance: Undecided → High
status: New → Fix Released
Changed in snapcraft (Ubuntu Xenial):
status: New → Confirmed
Changed in snapcraft (Ubuntu Yakkety):
status: New → Confirmed
Changed in snapcraft (Ubuntu Yakkety):
status: Confirmed → Fix Released
importance: Undecided → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers