Missing a qmake plugin

Bug #1574774 reported by Kyle Fazzari on 2016-04-25
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Snapcraft
Wishlist
Kyle Fazzari
snapcraft (Ubuntu)
Wishlist
Unassigned
Xenial
Wishlist
Unassigned
Yakkety
Wishlist
Unassigned

Bug Description

Now that Snappy runs on the desktop, Snapcraft needs a qmake plugin.

[Impact]

 * It is not easy to make a snap from a project that uses qmake.

[Test Case]

 * define a snapcraft.yaml for a project that uses qmake with qt4.
 * run snapcraft, install the snap and execute it.
 * define a snapcraft.yaml for a project that uses qmake with qt5.

[Regression Potential]

 * None, this is a new plugin.

Kyle Fazzari (kyrofa) on 2016-06-02
Changed in snapcraft:
milestone: none → 2.11
Changed in snapcraft:
status: New → Triaged
importance: Undecided → Wishlist
assignee: nobody → Kyle Fazzari (kyrofa)

+1, I'd love to see this.

Changed in snapcraft:
status: Triaged → In Progress
Changed in snapcraft:
status: In Progress → Fix Committed
Leo Arias (elopio) on 2016-06-27
description: updated

Hello Kyle, or anyone else affected,

Accepted snapcraft into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/snapcraft/2.12 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Leo Arias (elopio) wrote :

Tested in an up-to-date xenial:

- enabled -proposed
- update snapcraft to 2.12
- got kyle's demos for qt4 and qt4 projects, found a bug: https://bugs.launchpad.net/snapcraft/+bug/1596760
- uncompressed the file
- for both projects:
  - snapcraft
  - sudo snap install ...
  - text-editor
- checked that both projects work fine.

I'm going to mark this as verified, thanks Steve!

The bug reported in #1596760 was introduced in 2.12, but I think it shouldn't be a blocker for this release.

tags: added: verification-done
removed: verification-needed
Changed in snapcraft:
status: Fix Committed → Fix Released

The verification of the Stable Release Update for snapcraft has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

affects: Ubuntu Xenial → snapcraft (Ubuntu Xenial)
Changed in snapcraft (Ubuntu Xenial):
importance: Undecided → Wishlist
status: New → Fix Released
Changed in snapcraft (Ubuntu Xenial):
status: New → Confirmed
Changed in snapcraft (Ubuntu Yakkety):
status: New → Confirmed
Changed in snapcraft (Ubuntu Yakkety):
status: Confirmed → Fix Released
importance: Undecided → Wishlist
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers