ros example fails to snap

Bug #1544790 reported by Sergio Schvezov on 2016-02-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Snapcraft
High
Roufique hossain
snapcraft (Ubuntu)
High
Roufique hossain
Xenial
High
Roufique hossain
Yakkety
High
Roufique hossain

Bug Description

https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-xenial/xenial/amd64/s/snapcraft/20160211_234355@/log.gz

from catkin.builder import build_workspace_isolated\nImportError: No module named catkin.builder

To reproduce it:

./runtests.sh examples --filter ros --skip-install

[Impact]

 * The ROS example fails to snap in some environments. So far we have only seen it in CI, but there might be users with the same error.

[Test Case]

 * run snapcraft in the ros examples dir.

[Regression Potential]

 * None. On the fix that will land in the next SRU, we only modified the ROS test.

Changed in snapcraft:
milestone: none → 2.2.2
Changed in snapcraft:
importance: Undecided → High
assignee: nobody → Sergio Schvezov (sergiusens)
Changed in snapcraft:
status: New → Fix Released
Leo Arias (elopio) wrote :

It was not fixed, it was skipped. Lets keep this bug open so we don't forget to do a proper fix.

Changed in snapcraft:
status: Fix Released → Triaged
Changed in snapcraft:
status: Triaged → Fix Released
Leo Arias (elopio) wrote :

Sergio: why did you mark it as released again?

I found that I can reproduce this from a clean system. I'm not sure why I didn't get this error when I ran the tests locally, but I can now. Maybe my system was too dirty? Anyway, I bisected it, and this is a regression caused by:

elopio@calchas:~/workspace/canonical/snapcraft$ git bisect bad
fdab1bbab5ed6f17cc7007195bca9946b54e103d is the first bad commit
commit fdab1bbab5ed6f17cc7007195bca9946b54e103d
Author: Sergio Schvezov <email address hidden>
Date: Thu Feb 11 00:54:03 2016 -0300

    Replacing the need for pyversions

    pyversions creates a chicken and egg problem, so we use globbing
    to work around that.

    LP: #1541451

    Signed-off-by: Sergio Schvezov <email address hidden>

summary: - ros example fails in adt
+ ros example fails to snap
description: updated
Changed in snapcraft:
milestone: 2.2.2 → 2.9
Changed in snapcraft:
status: Fix Released → Fix Committed
Kyle Fazzari (kyrofa) on 2016-05-23
Changed in snapcraft:
status: Fix Committed → In Progress
Sergio Schvezov (sergiusens) wrote :
Changed in snapcraft:
assignee: Sergio Schvezov (sergiusens) → Leo Arias (elopio)
Leo Arias (elopio) on 2016-05-24
description: updated
Changed in snapcraft (Ubuntu):
milestone: none → xenial-updates
Changed in snapcraft (Ubuntu Yakkety):
milestone: xenial-updates → none
Changed in snapcraft (Ubuntu Xenial):
milestone: none → xenial-updates
Changed in snapcraft:
status: In Progress → Fix Committed
Changed in snapcraft:
status: Fix Committed → Fix Released
Changed in snapcraft (Ubuntu Xenial):
importance: Undecided → High
Changed in snapcraft (Ubuntu Yakkety):
importance: Undecided → High
Changed in snapcraft (Ubuntu):
assignee: nobody → Roufique hossain (rtatours)
Changed in snapcraft (Ubuntu Xenial):
assignee: nobody → Roufique hossain (rtatours)
Changed in snapcraft (Ubuntu Yakkety):
assignee: nobody → Roufique hossain (rtatours)
Changed in snapcraft:
assignee: Leo Arias (elopio) → nobody
assignee: nobody → Roufique hossain (rtatours)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers