Examples tests are generating an empty coverage file

Bug #1538643 reported by Leo Arias on 2016-01-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Snapcraft
Low
Leo Arias

Bug Description

Something on this commit made the examples coverage report to stop working:
https://github.com/ubuntu-core/snapcraft/commit/5e15b30203e285912da3e88fa55ddd8c4f66d6fa

It's weird, because the integrataion coverage is still working, and we use the same hack for both.

Leo Arias (elopio) wrote :

During today's standup I argued that the examples coverage is no longer useful because we have a pretty good unit test coverage, and nobody disagreed.

The value of the examples is for documentation, not for coverage. It's a nice safety net to prevent regressions, but that's not their main purpose.

Leo Arias (elopio) wrote :
Changed in snapcraft:
status: New → Incomplete
status: Incomplete → In Progress
importance: Undecided → Low
assignee: nobody → Leo Arias (elopio)
Changed in snapcraft:
milestone: none → 2.1
status: In Progress → Fix Committed
Changed in snapcraft:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers