Run the tests in xenial

Bug #1532213 reported by Leo Arias on 2016-01-08
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Snapcraft
High
Leo Arias

Bug Description

In our CI testing in travis, the tests are being run in trusty.

We need to run the tests in xenial.

[Impact]

 * For users, None.

 * Getting earlier results form a valid environment in travis will be good for developers.

[Test Case]

 * Review the results in travis.

[Regression Potential]

 * None. If the tests don't pass in travis, the pull request will not be merged.

Leo Arias (elopio) wrote :

We can use a lxc or docker in travis, move to jenkins and do the same, or get a xenial cloud slave in jenkins.

Leo Arias (elopio) wrote :
Changed in snapcraft:
status: New → In Progress
assignee: nobody → Leo Arias (elopio)
Changed in snapcraft:
importance: Undecided → High
milestone: none → 2.0
Changed in snapcraft:
milestone: 2.0 → none
Kyle Fazzari (kyrofa) on 2016-01-26
Changed in snapcraft:
status: In Progress → Fix Committed
Changed in snapcraft:
milestone: none → 2.1
Changed in snapcraft:
status: Fix Committed → Fix Released
Leo Arias (elopio) wrote :

We had to revert the lxc change because it started failing and got complex. I'll reopen this bug, and now we will try the docker approach.

Changed in snapcraft:
status: Fix Released → In Progress
milestone: 2.1 → 2.12
Changed in snapcraft:
status: In Progress → Fix Committed
Leo Arias (elopio) on 2016-06-27
description: updated

Hello Leo, or anyone else affected,

Accepted snapcraft into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/snapcraft/2.12 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Leo Arias (elopio) wrote :

There is nothing to verify related to this bug in xenial-proposed, so I'm marking it as verified.

Thanks Steve!

tags: added: verification-done
removed: verification-needed
no longer affects: Ubuntu Xenial
no longer affects: Ubuntu Yakkety
Changed in snapcraft:
status: Fix Committed → Fix Released

The verification of the Stable Release Update for snapcraft has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

no longer affects: Ubuntu Xenial
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers