can't install flatpak plugin

Bug #1871944 reported by Danilo Alculete on 2020-04-09
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
snap-store
Undecided
Unassigned

Bug Description

 There are some applications that are not available as snaps and are outdated on ubuntu archives and the workaround is to use flatpak. Since Gnome-software was removed it is impossible to install flatpak plugin on snap-store

AsciiWolf (asciiwolf) wrote :

Yeah, it would definitely be nice to have a Flatpak plugin in Snap Store that could be used if there is a flatpak installed on the host system.

Ken VanDine (ken-vandine) wrote :

This was an interface issue in snapd that was causing a problem with the apt backend, it was fixed with bug 1870184

Danilo Alculete (alculete) wrote :

The duplicated bug which you a linking is related to .debs not being available and this is solved indeed, but I was asking about flatpack plugin which seems to not be available yet

Andrew Hayzen (ahayzen) wrote :

You use the apt backend from the snap store to install the apt version of gnome software + flatpak plugin.

If you search for "gnome software" in the snap store, you'll be able to find the deb version, and then enable the flatpak plugin as normal. Then you can launch "Software" as normal from your applications (note not "Ubuntu Software").

Danilo Alculete (alculete) wrote :

well, it is good that is fixed and unfortunate, it would be great if snap-store also supported flatpacks so I wouldn't have the need to install a different store

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers