Ubuntu Software does not include .deb packages

Bug #1966142 reported by Gunnar Hjalmarsson
62
This bug affects 10 people
Affects Status Importance Assigned to Milestone
snap-store-desktop
Fix Released
Critical
Robert Ancell

Bug Description

.deb packages are not shown for me in latest jammy.

Tags: jammy
Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

Clarification: I'm on latest/stable (revision 558). Tried to upgrade to latest/edge (revision 575) but it didn't help.

In the "Installed" view my installed .deb files with AppStream metainfo are shown. But in the "Explore" view, when searching for applications, neither the installed nor the uninstalled .deb applications are listed.

If I pick an application, e.g. vlc, which is provided both as snap and .deb, and then open the menu at the top right, only the snap alternatives are shown.

GNOME Software works as expected, so the info is apparently available on my disk.

Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

Also, note that the very same revision (558) works as expected on impish.

Changed in snap-store-desktop:
status: New → Confirmed
importance: Undecided → Critical
assignee: nobody → Robert Ancell (robert-ancell)
Revision history for this message
Ken VanDine (ken-vandine) wrote :

I've confirmed this

On impish, snap-store rev 558 and rev 575 works fine. Displays information about both debian and snap packages.

On jammy (03252022), neither rev 558 nor rev 575 from the snap-store snap displays information about debian packages.

Note: This did work on jammy until recently, maybe early in March.

I've confirmed the pkcon works as expected within the confined snap-store snap on Jammy.

Revision history for this message
Robert Ancell (robert-ancell) wrote :

I've been trying to pinpoint where the issue is without much luck. Some ideas I've chased:

- Might be due to the sandboxing of the snap. Compiling the snap-store branch locally does work, but it is a slightly newer version than is in the snap (3.38.1 vs 3.38.0). I should try to build the git tag that the snap was built from.

- There might be a difference in the appstream data being generated for jammy. It is version 0.14 where impish is 0.12, however there doesn't seem to be any significant differences or any error messages indicating it's being ignored.

- Perhaps the icons for the .debs aren't being loaded - gnome-software tends to hide things that don't have all the required metadata. I'm not seeing any log messages from --verbose that my candidate .deb is being loaded at all (3dchess, as shown at the top of the games category when sorted by name).

Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

Note that gnome-software 41.5 works fine. Would it be an option to upgrade the gnome-software version in the snap?

Revision history for this message
Robert Ancell (robert-ancell) wrote :

Got it - in jammy /var/lib/app-info is a symlink:

$ ls /var/lib/app-info -dl
lrwxrwxrwx 1 root root 18 Mar 1 12:23 /var/lib/app-info -> /var/lib/swcatalog

We need to add /var/lib/swcatalog to the AppArmor rules for the appstream-metadata interface.

Changed in snap-store-desktop:
status: Confirmed → In Progress
Revision history for this message
Robert Ancell (robert-ancell) wrote :

Mailing list post about moving the location:
https://lists.freedesktop.org/archives/appstream/2022-February/000386.html

This was changed in AppStream 0.15.2:
Version 0.15.2
~~~~~~~~~~~~~~
Released: 2022-02-22

Features:
...
 * Support the new swcatalog catalog metadata location and add app-info fallback
...

Revision history for this message
Robert Ancell (robert-ancell) wrote :
Revision history for this message
Robert Ancell (robert-ancell) wrote :
Revision history for this message
Heinrich Schuchardt (xypron) wrote :

Why should a snap called snap-store show deb packages? This is not what I would expect as a user. At least the app should offer a filter to hide deb packages.

Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

It's branded as Ubuntu Software.

Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

This seems to be fixed now (works fine with today's daily build ISO). Thanks!

Changed in snap-store-desktop:
status: In Progress → Fix Released
Revision history for this message
corrado venturini (corradoventu) wrote :

In Ububtu 22.04 snap-store 41.3-59-gf884f48 575 latest/stable/… canonical✓ -
does not find btop deb version while existing in repository (also synaptic find it)

Revision history for this message
Marcos Alano (mhalano) wrote (last edit ):

I can corroborate the problem find by Corrado. Even after I install the package the Ubuntu Store just shows the Snap versions. I tested with gnome-logs and the Snaps and installed package show up. Maybe btop doesn't show because there is no metadata in /usr/share/metainfo directory (gnome-logs has).
The question is how to look for non-GUI tools (like btop itself) with Ubuntu Store

Revision history for this message
Marcos Alano (mhalano) wrote :

I installed GNOME Software, but I got the same result: btop just showed as Snap. I checked gnome-system-log (not gnome-logs) on GNOME and Ubuntu stores and get deb (there is no Snap), even there is no file for metadata in /usr/share/metainfo, but again, it's a GUI application, so I think the problem is with non-GUI apps only.

Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote (last edit ):

To be shown in Ubuntu Software (or GNOME Software) a .deb package must install either an AppStream metainfo file or a .desktop file in /usr/share/applications . gtop has neither, and hence it's not shown, while gnome-system-log has a .desktop file.

Revision history for this message
Marcos Alano (mhalano) wrote :

Thanks Gunnar, for the clarification. I think the current behavior is accordingly the expected. What do you think Corrado?

Revision history for this message
corrado venturini (corradoventu) wrote :

a .deb package must install either an AppStream metainfo file or a .desktop file in /usr/share/applications... before being installed?

Revision history for this message
Marcos Alano (mhalano) wrote (last edit ):

Corrado,

As the meme says, "well, yes, but actually no". The metadata for store is downloaded separated, it's not get from the installed package (at least for discovery part of the store). The metadata it's only generated in that two cases (AppStream available or .desktop file available). So if the application doesn't make AppStream file or .desktop available, it is impossible to generate metadata for that. This metadata is downloaded and with that, the apps show up in the store. You can read this file where you will find all the metadata: /var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_jammy_main_dep11_Components-amd64.yml.gz

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers