core18 contains var/lib/dbus/machine-id

Bug #1809107 reported by Olivier Tilloy on 2018-12-19
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
snap-core18
High
Łukasz Zemczak

Bug Description

While investigating a regression in the chromium snap (ibus input stopped working when rebasing the snap on core18), I straced the process and found out that it was using an incorrect dbus machine ID, which it reads from /snap/core18/current/var/lib/dbus/machine-id.

I suppose this is an unintended leftover from the build process.

Łukasz Zemczak (sil2100) wrote :

Yes, this is something we obviously missed. For core/core16 we used live-build to create the rootfs and apparently the removal of machine-id was done through livecd-rootfs, not our ubuntu-core specific hooks (i.e. the remove-dbus-machine-id chroot hook was being added through auto/config).

Changed in snap-core18:
assignee: nobody → Łukasz Zemczak (sil2100)
importance: Undecided → High
status: New → In Progress
Olivier Tilloy (osomon) wrote :

I tested revision 520 of the core18 snap (currently in the beta channel), and I confirm that the dbus machine-id is not present there, and that it fixes the regression I was observing in the chromium snap. Thanks!

Changed in snap-core18:
status: In Progress → Fix Committed
Changed in snap-core18:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers