snap-confine dmesg error and snap hangs

Bug #1681421 reported by Chris MacNaughton on 2017-04-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
snap-confine
Undecided
Jamie Strandboge

Bug Description

I'm trying to add a snap to Alacritty, my fork is at https://github.com/chrismacnaughton/alacritty, but whenever I try to run the built snap, there is no response and a single line goes into dmesg:

[36099.006669] audit: type=1400 audit(1491825708.546:25990): apparmor="DENIED" operation="file_inherit" profile="/usr/lib/snapd/snap-confine" name="/dev/tty" pid=1337 comm="snap-confine" requested_mask="wr" denied_mask="wr" fsuid=1000 ouid=0

Revision history for this message
Jamie Strandboge (jdstrand) wrote :

This particular denial is typically caused by debugging output. I'll add this to the snap-confine profile, but in the meantime, can you add to /etc/apparmor.d/usr.lib.snapd.snap-confine:

/dev/tty rw,

then run:
sudo apparmor_parser -r /etc/apparmor.d/usr.lib.snapd.snap-confine

Revision history for this message
Chris MacNaughton (chris.macnaughton) wrote :

Adding this line removes the dmesg error, the snap still is unresponsive though

Revision history for this message
Chris MacNaughton (chris.macnaughton) wrote :

this super simple rust program also fails, but only in classic mode: https://is.gd/wDGfHt

Revision history for this message
Michael Vogt (mvo) wrote :
Changed in snap-confine:
status: New → In Progress
Revision history for this message
Jamie Strandboge (jdstrand) wrote :

The apparmor denial fix is committed in master and should be in 2.24.

Changed in snap-confine:
assignee: nobody → Jamie Strandboge (jdstrand)
status: In Progress → Fix Committed
Zygmunt Krynicki (zyga) on 2019-10-15
Changed in snap-confine:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers