Slingshot opens with delay / unresponsively

Bug #1625775 reported by deesnook on 2016-09-20
44
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Slingshot
New
Undecided
Unassigned

Bug Description

In elementary Loki 0.4 Slingshot opens with noticeable delay while the other options in wingpanel open smoothly. See e.g. here: http://elementaryos.stackexchange.com/questions/7885/slignshot-delay-and-other-apps-loki

deesnook (deesnook) on 2016-09-20
description: updated
alexandr (alexandrpunk) wrote :

it also affects freya

Maxime Cornet (tenroc) wrote :

Strangely it seems that this bug has something to do with the focus mechanism.
For me it affects every applets in the panel but it is far more noticeable with slingshot.
For every other applets it just disable animation completely, causing them to open instantly but in a rather brutal way, whereas for slingshot, along with disabling the animation, it makes it pause mid opened for a second or so.
It happens every time I have a focused window on the screen (hence the "first time open impression" described in stackexchange).
After opening and closing a few applets, wingpanel somewhat steals focus (and the previously selected window become unfocused), and everything is smooth again.

Every second click Slingshot will speed up. In categories if I click on Office it will take a while to load.

There also seems to be a small lag in the wingpanel as well.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers