Slingshot App Launcher

Slingshot won't search while ibus is running

Reported by Daeng Bo on 2013-08-17
92
This bug affects 19 people
Affects Status Importance Assigned to Milestone
Slingshot
Critical
Jeremy Wootten

Bug Description

Steps to reproduce:
1) install ibus and run ibus-daemon
2) configure ibus with some language
3) super-space or click "Applications"
4) Try to type -- search isn't focused
5) click on search box -- still isn't focused

I have this problem with Chinese configured. Another user commented about the same problem with Japanese. The input method for these languages doesn't need to be enabled for the problem to occur -- trying it in English is enough.

Related branches

lp:~jeremywootten/slingshot/fix-1213321
Merged into lp:slingshot at revision 386
if (community): Needs Fixing on 2013-10-01
David Gomes: Approve on 2013-09-30
elementary Pantheon team: Pending requested 2013-08-26
asy (asypost) wrote :

not only ibus,but also fcitx.

Cody Garver (codygarver) wrote :

I hear about this a lot, so I confirmed it.

no longer affects: elementaryos
Changed in slingshot:
milestone: none → isis-beta1
importance: Undecided → Critical
status: New → Confirmed

I confirm this happen to me too.
To Cody.
Any idea about the patch of this bug will come to Luna stable instead updating to Isis beta?..
i don't want to go on beta in first place.

Cody Garver (codygarver) wrote :

The fix would be available to Luna users as well, it's just on Isis beta milestone so it gets seen.

Tigran Gabrielyan (tigrangab) wrote :

When you try to type with ibus-daemon running I get an infinite loop of :

[Gdk] Event with type 8 not holding a GdkDevice. It is most likely synthesized outside Gdk/GTK+

Happens after calling return base.key_press_event (event); anywhere inside the overridden key_press_event method in SlingshotView.vala

Tigran Gabrielyan (tigrangab) wrote :

Just for clarity, calling return base.key_press_event (event); gives that GDK message and then public override bool key_press_event (Gdk.EventKey event) in SlingshotView is called again and again it calls return base.key_pres_event. That's where the infinite loops is.

Ohh yeahh.. added some more about this bug... when ibus daemon is turned on, i can't use the hotkey to run the Terminal (Ctrl+Alt+T) .. does the hotkey is a part of slingshot too? ..

Hey.. sorry for double post, but... to ibus users on elementaryOS. i don't know if this work for you all or not, but it does something magic happen to me.
I suddenly can make the ibus work on search on slingshot, before that magic happen work. i quit the daemon first.. then i try to run the daemon back again by typing the daemon name "ibus-daemon" on the search bar and run it as command. then i try to type it and it works... :D..
i'm sorry i can't make a prove of the bugs is figured out, its because my desktop can't do a screenshot (black screen) after installing fglrx :( ..

I'm sorry again for my triple post.. but here it is for the screenshot of the prove.. It works to trigger the ibus character, but when the characters are finalized (non underlined) we still can't delete or backspace it if we made a mistake

I find also one at the scratch .
it is also unable to type in scrathch when ibus is running.

Jonathan Lumb (jonolumb) wrote :

There is already a bug filed for the problem in Scratch which may or may not be related:

https://bugs.launchpad.net/scratch/+bug/1198794

Changed in slingshot:
assignee: nobody → Jeremy Wootten (jeremywootten)
Cody Garver (codygarver) wrote :

From duplicate report #1220214:

"I bet all eastasia user have this problem.
If you want to reproduce this:
apt-get install fcitx-pinyin
then go to language panel, and change the input method to fcitx, logout,
login.
press Super + Space to open slingshot. You'll find you can not type in
anything.
Here is a video: http://www.youtube.com/watch?v=9QNrdtXdGmY

(ibus and fcitx are two input methods, widely use in eastasia)

Have a good day!"

Thank you Cody ,but unfortunately fcitx either doesn't wok for HANGUL ( Korean Laungae)
Actually For a Hangul nabi works propely

apt-get install nabi

but , I don't know hot to input nabi's indicator to the wingpanel
so that I son't use nabi yet

if you can show me how to move nabi's indicator to wingpanel
it will be a good news for us

Kevin (kevinshlee) wrote :

As far as I know, fcitx is only for Chinese and Chinese is not the only language used by east Asian people. Korea, Japan and Mongolia have their own languages. They also use different alphabets, although Mongolia uses Mongolian Cyrillic alphabet which is equivalent to Russian one with some additional characters.

For Korean alphabet, I don't think using nabi is a good alternative since it may not work well with some applications (I had this problem before). I'm not sure if the old nabi problem with several applications was already fixed though.

I think a proper and right solution would be making slingshot work well when ibus is running. So rather than suggesting some alternatives, this issue should be solved properly.

Jonathan Lumb (jonolumb) wrote :

Thanks for sharing your world knowledge with us Kevin...

Kevin (kevinshlee) wrote :

Well, I understand that if you don't use it, you can't easily know what it is or what the problem is.
By the way, speaking of knowledge, here is more enjoyable knowledge although you might not find it funny if you're not Asian. :)
http://www.youtube.com/watch?v=zAH8MgWk43w

Changed in slingshot:
status: Confirmed → Fix Committed
Changed in slingshot:
status: Fix Committed → In Progress
Jonathan Lumb (jonolumb) wrote :

Seems to be fixed in the latest version for me.

Cody Garver (codygarver) on 2013-10-05
Changed in slingshot:
milestone: isis-beta1 → 0.7.6
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers