Slingshot’s left sidebar is not flexible, shows long strings in two rows

Bug #1094370 reported by tanot18 on 2012-12-28
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Slingshot
Fix Released
Medium
Corentin Noël

Bug Description

"System Tools" is "Herramientas del sistema" in Spanish. The translation doesn't fit in the left sidebar and it's shown in two rows. Same happens for other languages.

Note that this is *not* a translation issue, and it should not be "fixed" with shorter --and possibly unsuitable-- translations. Slingshot could ellipsize the string or could increase the width of the sidebar a bit.

Thanks

Related branches

Cody Garver (codygarver) on 2012-12-28
affects: elementaryos → slingshot
Changed in slingshot:
assignee: nobody → elementary Spanish Translators (elementary-l10n-es)
Adolfo Jayme (fitojb) wrote :

It's not possible to shorten the translation without making it meaningless. Why it's wrong to show the string in two rows? If it does look ugly, it's not a translation bug, but a Slingshot one.

Alfredo Hernández (aldomann) wrote :

Sorry, but I can't find the string within Slingshot translatable strings, so I'm not able to change it.

Why does it look ugly? Slingshot's supposed to display long titles on two
lines

tanot18 (tonytoh1) wrote :

Adolfo Jayme:Entiendo que no es un error de traducción pero no sabia muy bien como hacer llegar mi opinión y que se debatiera al respecto. (previamente use google+ y facebook para tratar desde ahí hacer llegar mi punto de vista, pero no recibí respuesta)
Entiendo que de hacer el cambio solo seria para mejorar el aspecto estético pero en contexto general, No es lo que el proyecto elementary busca?.. un mejor aspecto e integración de la interfaz gráfica.
También creo que acortar la traducción no perdería completamente el sentido. Creo que intuitivamente se entiende que la categoría "Sistemas" se refiere a herramientas o aplicaciones que tienen que ver con la configuración del sistema. Así que difiero con tu punto de vista.
Andrea Basso:Si, efetivamente. La mala apariencia la genera que el titulo de la categoria se muestra en dos lineas. Y observando desde tu punto de vista, una posible solucion podria ser que Slingshot mostrara el titulo en una sola linea.
Tambien podria dejarse a criterio de los usuarios que usan Elementary Os en Español o idiomas similares, por ejemplo:https://www.facebook.com/photo.php?fbid=497037727007406&set=o.137760676255770&type=1&ref=notif&notif_t=like&theater
Saludos

> Date: Fri, 28 Dec 2012 23:30:08 +0000
> From: <email address hidden>
> To: <email address hidden>
> Subject: [Bug 1094370] Re: Change translation of "System Tools" menu in Slingshot
>
> It's not possible to shorten the translation without making it
> meaningless. Why it's wrong to show the string in two rows? If it does
> look ugly, it's not a translation bug, but a Slingshot one.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1094370
>
> Title:
> Change translation of "System Tools" menu in Slingshot
>
> Status in Slingshot:
> New
>
> Bug description:
> The translated to Spanish, please change "Herramientas del Sistema"
> for only "Sistema" or "Herramientas".. because in Slingshot
> "Herramientas del Sistema" is showed in two row and not is nice.
>
> Thanks
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/slingshot/+bug/1094370/+subscriptions

That's why we have a translators team -the users shouldn't decide about translations unless they are part of the team. We are proficient on translating software; and Adolfo is right, Sistema is completely different from Herramientas del sistema. This is a Slingshot bug, not a translation one.

Adolfo Jayme (fitojb) wrote :

Slingshot shouldn't hardcode measurements -- its sidebar should be flexible so it doesn't show long strings in two rows. Or maybe it could use ellipsizing.

summary: - Change translation of "System Tools" menu in Slingshot
+ Slingshot’s left sidebar is not flexible, shows long strings in two rows
Changed in slingshot:
assignee: elementary Spanish Translators (elementary-l10n-es) → nobody
Adolfo Jayme (fitojb) on 2013-01-03
description: updated

Adolfo Jayme: I agreed, with you changed of description
Thank you by translation and summary.

Changed in slingshot:
importance: Undecided → Medium
status: New → Confirmed
Changed in slingshot:
milestone: none → luna-beta3

I can't see a problem with that personally. But sounds like a wishlist bug to me either way.

Cody Garver (codygarver) wrote :

Design team, is this the desired appearance?

Changed in slingshot:
assignee: nobody → elementary UX Team (elementary-design)
Daniel Fore (danrabbit) wrote :

It's not terrible, but Harvey and I think it'd be better if we were to remain consistent with source lists in apps and keep items to a single line.

Changed in slingshot:
assignee: elementary UX Team (elementary-design) → nobody
Daniel Fore (danrabbit) on 2014-05-21
Changed in slingshot:
milestone: isis-beta1 → isis+1-beta1
Daniel Fore (danrabbit) on 2014-10-15
Changed in slingshot:
status: Confirmed → In Progress
assignee: nobody → Corentin Noël (tintou)
Corentin Noël (tintou) on 2014-10-16
Changed in slingshot:
status: In Progress → Fix Committed
milestone: isis+1-beta1 → freya-beta2
Daniel Fore (danrabbit) on 2015-02-09
Changed in slingshot:
status: Fix Committed → Fix Released
Cody Garver (codygarver) on 2015-04-06
Changed in slingshot:
milestone: freya-beta2 → 0.8
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments