Slingshot App Launcher

Weird positioning on dual monitor

Reported by Jaap Broekhuizen on 2012-06-03
96
This bug affects 18 people
Affects Status Importance Assigned to Milestone
Slingshot
High
Unassigned

Bug Description

When using dual monitor setup, the window is not positioned right, see screenshot.

Fabian Thoma (agent00tai) wrote :

Wingpanel seems to be positioned correctly, this is a slingshot bug

Changed in wingpanel:
status: New → Invalid
tags: added: fixed-as-indicator
Andrea Basso (voluntatefaber) wrote :

I don't think this has been fixed, but since there have been some work on Popovers in Granite, I don't remember if we already had Gala back then when this was reported, is this still happening?

I can confirm, this is still happening on both of my machines, when multiple (two) monitors are in use.
Normal placement, when using just one screen.

Changed in slingshot:
status: New → Confirmed
Cassidy James (cassidyjames) wrote :

Exact issue happening still for me with two displays, similar setup.

Changed in slingshot:
importance: Undecided → High
milestone: none → luna-beta2
Cassidy James (cassidyjames) wrote :

It looks like other Granite popovers act properly on the second, larger display (I moved a window so the popover's spawn point was at 0,0), with the popover only appearing on the right display. So this is more than likely a Slingshot-specific issue?

Daniel Nadeau (daniel-nadeau01) wrote :

Cassidy, if you unplug the monitor, and re-plug it in, is it the same?

Daniel Nadeau (daniel-nadeau01) wrote :

As in, if you leave Slingshot open, does it still do that when you unplug and plug?

Gianfranco Micoli (gianfrix-mg) wrote :

FYI I tried Slingshot on a multi monitor setup (external monitor on the left) and using Gala the launcher is partially placed like the screenshots above, if using another WM like XFWM it correctly places... may it be a gala bug too?

Jaap Broekhuizen (jaapz-b) wrote :

I don't know about anyone else with a dual monitor setup, but I cannot reproduce this bug anymore.

Jaap Broekhuizen (jaapz-b) wrote :

Nevermind, i can, i was testing it wrong! I will now try if the position-fix branch actually fixes it here.

Jaap Broekhuizen (jaapz-b) wrote :

The provided fix does not work for me.

Jaap Broekhuizen (jaapz-b) wrote :

This fix works for me, i stole it from tom beckmann's move-to-rect branch. That branch does not compile for me, but this one does: lp:~jaapz-b/slingshot/position-fix. Putting in a merge request.

Cody Garver (codygarver) on 2012-11-20
no longer affects: wingpanel
Eduard Gotwig (gotwig) wrote :

Is this bug still present?

Cody Garver (codygarver) wrote :

Yes.

Tim Wolfers (timwolfers) wrote :

This bug is still affecting my dual monitor setup. I've updated my laptop yesterday to the latest versions of the software, including wingpanel. Still the same.

No, I updated my video driver to NVIDIA accelerated graphics driver
(post-release updates) (version current-updates) which seemed tp resolve
the problem.

On 12/21/2012 12:00 AM, Eduard Gotwig wrote:
> Is this bug still present?
>

Changed in slingshot:
assignee: nobody → Akshay Shekher (voldyman)
Daniel Fore (danrabbit) on 2012-12-30
Changed in slingshot:
milestone: luna-beta2 → luna-beta3
Changed in slingshot:
assignee: Akshay Shekher (voldyman) → nobody
Cody Garver (codygarver) wrote :

Appears to be fixed. See attachment.

Changed in slingshot:
status: Confirmed → Fix Committed
milestone: luna-beta3 → luna-beta2
Cody Garver (codygarver) on 2013-04-09
Changed in slingshot:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers